Bug 55633 - up2date redownloads the package if two releases are installed
Summary: up2date redownloads the package if two releases are installed
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-03 12:24 UTC by Krzysio (Chris) Leszczynski
Modified: 2015-01-07 23:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-06 19:53:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2001:119 normal SHIPPED_LIVE New up2date and rhn_register clients available 2001-10-03 04:00:00 UTC

Description Krzysio (Chris) Leszczynski 2001-11-03 12:24:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
I have installed kernel-2.4.9-7 and kernel-2.4.9-13, now up2date
redownloads kernel-2.4.9-13 each time I run up2date.

Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
Install any two releases of the same package (kernel is a good
example).

Actual Results:  up2date sees only the first reelases and tries to upgrade
it even if the next version is already installed..

Expected Results:  I would expect up2date to check the presence of all
release. Perhaps it should warn about such things and offer the possibility
to remove one of them. I am not sure whether it should.

Additional info:

I believe the bug will disapear just after I reboot the machine and delete
the old kernel. But I must keep the old kernel until I reboot the machine.

Comment 1 Adrian Likins 2001-11-05 22:47:00 UTC
This is indeed a bug. Should be fixed in the next release of the package. 


Comment 2 Bill Crawford 2001-11-06 13:36:13 UTC
Oddest part is that the package that's being offered *should* have been removed
from the list of available updates ... or is that the bug?


Comment 3 Bill Crawford 2001-11-06 13:37:57 UTC
Oddest part is that the package that's being offered *should* have been removed
from the list of available updates ... or is that the bug?


Comment 4 Bill Crawford 2001-11-06 13:38:57 UTC
(That shouldn't have been repeated, sorry ... going to file a bug against
bugzilla now ...)

Comment 5 Adrian Likins 2001-11-06 19:53:50 UTC
Yeah, thats the problem. Basically, because of their being multiple
kernel packages installed, it seems the old one and thinks it needs
to be updated.

This used to work, but some changes to make stuff more picky about
package arch broke the code that detects this case.

Comment 6 David M. Cook 2002-02-22 17:25:43 UTC
Fix: http://www.redhat.com/support/errata/RHBA-2001-119.html


Note You need to log in before you can comment on or make changes to this bug.