Bug 55635 - es1370 not working in 7.2
Summary: es1370 not working in 7.2
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-03 13:50 UTC by Richard Allen
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-01 16:16:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard Allen 2001-11-03 13:50:03 UTC
In older versions og RedHat my soundcard has been working fine with es1370.

02:0a.0 Multimedia audio controller: NexGen Microsystems: Unknown device 5000
        Subsystem: Unknown device 4942:4c4c
        Flags: slow devsel, IRQ 9
        I/O ports at b800 [size=64]

[root@morticia root]# modprobe es1370
/lib/modules/2.4.9-7/kernel/drivers/sound/es1370.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
/lib/modules/2.4.9-7/kernel/drivers/sound/es1370.o: insmod /lib/modules/2.4.9-7/kernel/drivers/sound/es1370.o failed
/lib/modules/2.4.9-7/kernel/drivers/sound/es1370.o: insmod es1370 failed

Comment 1 Bill Nottingham 2001-11-05 15:30:03 UTC
Does the PCI id show up the same on older kernels?

I ask because the one you posted is 1074:5000, while the normal es1370
id is 1274:5000.


Comment 2 Richard Allen 2001-11-05 15:48:50 UTC
[root@xo root]# hostname
xo.hp.is
[root@xo root]# cat /etc/redhat-release
Red Hat Linux release 7.2 (Enigma)
[root@xo root]# uname -a
Linux xo.hp.is 2.4.7-10 #1 Thu Sep 6 17:27:27 EDT 2001 i686 unknown
[root@xo root]# lsmod
es1370                 25440   1  (autoclean)
gameport                1936   0  (autoclean) [es1370]
soundcore               4464   4  (autoclean) [es1370]
[root@xo root]# lspci -v
01:02.0 Multimedia audio controller: Ensoniq ES1370 [AudioPCI]
        Subsystem: Unknown device 4942:4c4c
        Flags: bus master, slow devsel, latency 96, IRQ 5
        I/O ports at 2480 [size=64]

On this system it works fine.



[root@morticia root]# hostname
morticia.ra.is
[root@morticia root]# cat /etc/redhat-release
Red Hat Linux release 7.2 (Enigma)
[root@morticia root]# uname -a
Linux morticia.ra.is 2.4.9-7 #1 Thu Oct 18 13:47:25 EDT 2001 i686 unknown
02:0a.0 Multimedia audio controller: NexGen Microsystems: Unknown device 5000
        Subsystem: Unknown device 4942:4c4c
        Flags: slow devsel, IRQ 9
        I/O ports at b800 [size=64]


Same id on both systems (4942:4c4c).  Can it be sonething in the difference
between 2.4.7-10 to 2.4.9-7 ?


Comment 3 Richard Allen 2002-10-01 16:16:03 UTC
Well, 7.3 came, then 8.0 and the card works fine ;)    I guess this can be
closed now ;)

Comment 4 Richard Allen 2002-11-07 15:39:09 UTC
Hrmph :)  



Note You need to log in before you can comment on or make changes to this bug.