Bug 55639 - Anaconda crashes during kickstart install
Summary: Anaconda crashes during kickstart install
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-03 19:00 UTC by John Hanks
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-06 15:53:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Saved debug stuff from a crashed install attempt (37.26 KB, text/plain)
2001-11-03 19:03 UTC, John Hanks
no flags Details

Description John Hanks 2001-11-03 19:00:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Anaconda crashes during kickstart install, asks meto save the crash
information and submit a bug report.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Attempt a kickstart install with the attached ks.cfg (or one of several
variations)
	

Actual Results:  Anaconda crashes

Expected Results:  Successful install

Additional info:

ks.cfg:

#Generated by Kickstart Configurator
lang en_US
langsupport en_US
keyboard us
mouse none
device ethernet eepro100
timezone --utc America/Denver
rootpw --iscrypted $1$hrQ.52Qm$26xlwZUVhWR1Bsl1vQgce.
reboot
bootloader --location=mbr
install
url --url http://master.beowulf.usu.edu/redhat
network --bootproto dhcp
auth  --useshadow  --enablemd5
firewall --disabled
clearpart --all
part /boot --fstype ext3 --size 64
part  swap --size 1024
part / --fstype ext3 --size 1024 --grow
#Do not configure the X Window System
skipx
%packages
@Classic X Window System
@X Window System
@Network Support
@Network Managed Workstation
@Utilities

Comment 1 John Hanks 2001-11-03 19:03:25 UTC
Created attachment 36302 [details]
Saved debug stuff from a crashed install attempt

Comment 2 John Hanks 2001-11-03 21:38:14 UTC
I have been trying different ks.cfg variations as I install on different
machines and I now believe the problem is with the specification of the URL for
the http install method. I couldn't find a way to make it work, but when the url
is left out of ks.cfg and specified manually things work ok. Still not as useful
as a completely silent install, but better than manually configuring everything.

Comment 3 Brent Fox 2001-11-06 04:27:59 UTC
What are the contents of the redhat/ directory on master.beowulf.usu.edu?

Comment 4 John Hanks 2001-11-06 15:53:17 UTC
The redhat iso's are mounted on loop devices as

http://master.beowulf.usu.edu/redhat/disc1
http://master.beowulf.usu.edu/redhat/disc2

I have opened up the external interface so you can see this at

http://glaber.biology.usu.edu/redhat

Comment 5 Brent Fox 2001-11-08 20:14:03 UTC
I think that the easiest thing thing to do is to copy the contents of the ISOs
to the NFS server instead of loopback mounting the ISOs.  That should solve all
the problems.


Note You need to log in before you can comment on or make changes to this bug.