Bug 55646 - Update Agent always thinks kernel-2.4.9-12 need to be installed
Update Agent always thinks kernel-2.4.9-12 need to be installed
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-03 18:40 EST by Robert Nichols
Modified: 2015-01-07 18:52 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-05 01:58:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Nichols 2001-11-03 18:40:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.9-6 i586; Nav)

Description of problem:
Even after Update Agent has just installed kernel-2.4.9-12, if I run
up2date again it still reports that I need to upgrade to kernel-2.4.9-12. 
If I run "rpm -q kernel" it correctly reports that I have kernel-2.4.2-2,
kernel-2.4.9-6, and kernel-2.4.9-12 installed.
If I allow up2date to install the kernel again, "rpm -q kernel" now reports
that I have kernel-2.4.9-12 installed _twice_.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run up2date (configured for automatic installation) when current kernel
version < 2.4.9-12
2.Run up2date again.
3.
	

Additional info:

Running up2date-2.5.4-1.i386
kernel-source-2.4.9-12 not installed
Comment 1 Robert Nichols 2001-11-03 19:07:07 EST
Problem persists even when I am booted and running on kernel-2.4.9-12.
Comment 2 Adrian Likins 2001-11-05 15:12:54 EST
I think I see what is causing this problem. 

There should be a fix in the next release of the client.
Comment 3 Curtis Doty 2001-12-05 01:58:20 EST
Problem went away on at least one my my boxes running i586 kernel. Yipee.

../C
Comment 4 David M. Cook 2002-02-22 12:24:27 EST
Fixed in http://www.redhat.com/support/errata/RHBA-2001-119.html

Note You need to log in before you can comment on or make changes to this bug.