Bug 556691 - Alt text of an image displays chapter title and not that of the textobject tag
Alt text of an image displays chapter title and not that of the textobject tag
Status: CLOSED NOTABUG
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Joshua Wulf
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-18 23:43 EST by Isaac Rooskov
Modified: 2015-07-13 00:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-21 01:40:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
A file that includes the code which isn't being rendered correctly (26.76 KB, text/xml)
2010-01-19 17:41 EST, Isaac Rooskov
no flags Details

  None (edit)
Description Isaac Rooskov 2010-01-18 23:43:00 EST
Description of problem:

Alt text of an image displays chapter title and not that of the textobject tag

Version-Release number of selected component (if applicable):

1.3

How reproducible:

100%

Steps to Reproduce:
1. place an image into a publican book with the mediaobject tag and include a textobject with a sentence about the image
2. build the book
3. view the book via a web browser and notice that the alt text reads that of the chapter title and not of the alt text specified in the xml
  
Actual results:

Alt text of an image displays chapter title and not that of the textobject tag

Expected results:

the textobject text should be displayed to the user as the alt text. This is important for blind readers

Additional info:

None
Comment 1 Jeff Fearn 2010-01-19 17:28:23 EST
Please link to or attach an example of the actual XML you are using.

Cheers, Jeff.
Comment 2 Isaac Rooskov 2010-01-19 17:41:56 EST
Created attachment 385551 [details]
A file that includes the code which isn't being rendered correctly

Do a search for the <textobject> tag and that's the part that should show up as the tooltip but instead the chapter title does.
Comment 3 Jeff Fearn 2010-01-19 18:56:53 EST
(In reply to comment #0)
> the textobject text should be displayed to the user as the alt text. This is
> important for blind readers

The tool tip text is not generated from the the alt attribute, it is generated from the title attribute.

The alt text is set correctly and there is no affect on accessibility for blind readers.

The other use in DocBook for the textobject is to display the text below the image, as shown at http://www.docbook.org/tdg/en/html/imageobject.html, this is controlled by enabling html.longdesc in the XSL. We turned this off a ling time ago because people didn't like it.

You will need to discuss html.longdesc on the list if you want it changed.

You will need to discuss setting the title attribute on the image if you want that changed.

The browser is displaying the chapter title as the tool tip because there is no title attribute for the image and your browser is defaulting to the title for the containing object. This behavior probably differs between browsers.

Cheers, Jeff.
Comment 4 Isaac Rooskov 2010-01-19 20:20:25 EST
Hey Jeff, 

I know I'm confused so I was wondering if you could help me understand a bit better (because I am having an issue with the alt tag stuff in maven but for different reasons and understanding more might help me solve both the maven and publican issue on my end).

This is the figure information that is in the file that is attached:

<figure id="figu-Beginners_Guide-Visual_Web_Tools-Visual_Page_Editor">
	<title>Visual Page Editor</title> 
	<mediaobject>
		<imageobject>
			<imagedata fileref="images/figu-Beginners_Guide-Visual_Web_Tools-Visual_Page_Editor.png" format="PNG" width="444" />
		</imageobject>
		<textobject>
			<phrase>
				The Visual Page Editor, showing both the source and a visual preview simultaneously.
			</phrase>
		</textobject>
	</mediaobject>
</figure>

To me it looks like the title attribute for the image is set, is there a different title attribute I should be looking in to?

Thanks, 

Isaac
Comment 5 Jeff Fearn 2010-01-19 20:40:20 EST
(In reply to comment #4)
> Hey Jeff, 
> 
> I know I'm confused so I was wondering if you could help me understand a bit
> better (because I am having an issue with the alt tag stuff in maven but for
> different reasons and understanding more might help me solve both the maven and
> publican issue on my end).
> 
> This is the figure information that is in the file that is attached:
> 
> <figure id="figu-Beginners_Guide-Visual_Web_Tools-Visual_Page_Editor">
>  <title>Visual Page Editor</title> 
>  <mediaobject>
>   <imageobject>
>    <imagedata
> fileref="images/figu-Beginners_Guide-Visual_Web_Tools-Visual_Page_Editor.png"
> format="PNG" width="444" />
>   </imageobject>
>   <textobject>
>    <phrase>
>     The Visual Page Editor, showing both the source and a visual preview
> simultaneously.
>    </phrase>
>   </textobject>
>  </mediaobject>
> </figure>
> 
> To me it looks like the title attribute for the image is set, is there a
> different title attribute I should be looking in to?

Hi Isaac, if you check the HTML output you will see that it contains something like:

<img src="images/figu-Beginners_Guide-Visual_Web_Tools-Visual_Page_Editor.png" alt="The Visual Page Editor, showing both the source and a visual preview simultaneously." width="444">

The IMG alt tag is set correctly. If you disable images this alt text will be displayed. If you use a reader for the blind this text will be spoken.

The display you are talking about is not alt text, it is tool tip text. The tool tip text would need to be set by adding another attribute, title, to the IMG output. Basically the display you are talking about would require duplicating the content of alt in the title attribute.

There is nothing in the DocBook XSL to set the title attribute in the IMG tag, so we'd have to add this functionality.

Cheers, Jeff.
Comment 6 Isaac Rooskov 2010-01-19 20:44:57 EST
Ah! The lightbulb goes on....

Thanks for the explanation in n00b terms ;)
Comment 7 Jeff Fearn 2010-01-21 01:40:51 EST
Isaac if you want to change the way the tool tip text is displayed, please discuss it on the list and open a new bug with what ever is decided.

Cheers, Jeff.

Note You need to log in before you can comment on or make changes to this bug.