Bug 55675 - XFree86 fails to load (ATI Radeon Mobility M6)
XFree86 fails to load (ATI Radeon Mobility M6)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 55710 56525 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-04 10:35 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-23 03:30:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of lspci -n (537 bytes, text/plain)
2001-11-05 08:46 EST, Need Real Name
no flags Details
output of lspci -vn (3.16 KB, text/plain)
2001-11-05 08:46 EST, Need Real Name
no flags Details
XF86Config-4 (1.89 KB, text/plain)
2001-11-05 08:48 EST, Need Real Name
no flags Details
/var/log/XFree86.0.log (19.20 KB, text/plain)
2001-11-05 08:49 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-11-04 10:35:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.4-4GB i686)

Description of problem:
XFree86 fails to load on my Fujitsu E series Lifebook (E-6644).
Graphics card: ATI Radeon Mobility M6 (16 mb ram)
Error: "Failed to detect panel size"
Possibly caused by the failure to read DCC information (see log)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
startx

Actual Results:  XFree86 fails to start up, with "Screen(s) found, but none
have a usable configuration." error. 

Expected Results:  XFree86 starts up as normal.

Additional info:

Please see the URL: http://www.doc.ic.ac.uk/~jak97/radeon/index.html for
XF86Config-4 and XFree86.0.log files.
Thanks.
Comment 1 Mike A. Harris 2001-11-04 21:18:47 EST
Please attach the files individually via the link below.  Bug reports
may require some time before a fix is available, and if the info
is not directly in the bug report, someone's web/ftp URL may vanish
over time, or they may delete the files.  If they are attached to
the bug report, they are readily available to all developers as long
as the bug report remains open.

Can you please also attach the output of "lspci -n" and "lspci -vn".
Thanks.
Comment 2 Need Real Name 2001-11-05 08:46:00 EST
Created attachment 36443 [details]
output of lspci -n
Comment 3 Need Real Name 2001-11-05 08:46:49 EST
Created attachment 36444 [details]
output of lspci -vn
Comment 4 Need Real Name 2001-11-05 08:48:36 EST
Created attachment 36445 [details]
XF86Config-4
Comment 5 Need Real Name 2001-11-05 08:49:42 EST
Created attachment 36446 [details]
/var/log/XFree86.0.log
Comment 6 Anders Hermansen 2001-11-08 09:17:18 EST
I have a different ATI card but the same problemt. Look at my bug #55013 and 
see if my solution can help you.
Comment 7 Mike A. Harris 2001-11-19 04:57:16 EST
jak97@doc.ic.ac.uk:  Does the solution in bug #55013 fix the problem
for you?

Comment 8 Need Real Name 2001-11-19 06:11:13 EST
Hi, 

The solution mentioned in bug #55013 did not work for me, however, ATI have 
recently contributed some fixes to the XFree86 CVS which make the Radeon 
Mobility work perfectly.

Thanks
John
Comment 9 Mike A. Harris 2001-11-23 03:24:16 EST
*** Bug 55710 has been marked as a duplicate of this bug. ***
Comment 10 Mike A. Harris 2001-11-23 03:28:23 EST
*** Bug 56525 has been marked as a duplicate of this bug. ***
Comment 11 Mike A. Harris 2002-07-26 07:09:08 EDT
Ok, closing as fixed in CURRENTRELEASE (RHL 7.3) then, since the
CVS code from the time of the last comment would be XFree86 4.2.0
which is part of RHL 7.3.


Note You need to log in before you can comment on or make changes to this bug.