Bug 55692 - convert fails on .xpm -> .bmp
convert fails on .xpm -> .bmp
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ImageMagick (Show other bugs)
7.2
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-04 20:03 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-09 11:43:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test image (560 bytes, image/xpm)
2001-11-05 22:48 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-11-04 20:03:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
The convert program cannot convert .xpm files to .bmp files.  This worked
in 7.1.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.create .xpm file with gimp (any xpm file seems to fail)
2.convert -compress None blat.xpm blat.bmp
3.tada!


Actual Results:  The output:
convert: Unexpected end-of-file (blat.xpm) [No such file or directory].
convert: Missing an image file name.


Expected Results:  Creation of file blat.bmp in .bmp format

Additional info:
Comment 1 Bernhard Rosenkraenzer 2001-11-05 06:54:31 EST
Works for me... Are you sure you're in the correct directory and didn't mistype anything? 
Comment 2 Need Real Name 2001-11-05 22:48:18 EST
Created attachment 36561 [details]
Test image
Comment 3 Need Real Name 2001-11-05 22:59:17 EST
With the above image, and the following command line, I get the described bug:
"convert blat.xpm blat.bmp".

I'm using a stock 7.2 install with updates.

Other info:
ImageMagick-5.3.8-3
glibc-2.2.4-19 (i686 update i think)
Running ltrace reveals convert is failing in ReadImage in libMagick.so.5 (I
think, anyway, that function is returning zero then exiting).  strace reveals
none of the open system calls fail.
Comment 4 Need Real Name 2001-11-08 13:25:49 EST
Reverting to the rh7.1 version (ImageMagick-5.2.7-2) makes this problem go away.
Comment 5 Bernhard Rosenkraenzer 2001-11-09 10:00:01 EST
Do you still see this with 5.4.x (from rawhide)?
Comment 6 Need Real Name 2001-11-09 11:43:32 EST
Yes, the problem goes away with ImageMagick-5.4.0.3-1.

Note You need to log in before you can comment on or make changes to this bug.