Bug 557271 - [abrt] crash in smolt-1.4-4.fc12
[abrt] crash in smolt-1.4-4.fc12
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
abrt_hash:a5d27435
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-20 16:18 EST by Jay Mist
Modified: 2010-02-09 03:29 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-27 14:27:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (1.89 KB, text/plain)
2010-01-20 16:18 EST, Jay Mist
no flags Details

  None (edit)
Description Jay Mist 2010-01-20 16:18:37 EST
abrt 1.0.3 detected a crash.

Comment: Tried to send Smolt client data.

backtrace
-----
Summary: TBa5d27435 smolt.py:375:serverMessage:ServerError: 'Could not contact server: Critical [20]: Invalid Token - Likely A timeout, please try again.'

Traceback (most recent call last):
  File "/usr/bin/smoltSendProfile", line 261, in <module>
    proxies=proxies)
  File "/usr/share/smolt/client/smolt.py", line 595, in send
    pub_uuid = serverMessage(o.read())
  File "/usr/share/smolt/client/smolt.py", line 375, in serverMessage
    raise ServerError, _('Could not contact server: %s') % line.split('ServerMessage: ')[1]
ServerError: 'Could not contact server: Critical [20]: Invalid Token - Likely A timeout, please try again.'

Local variables in innermost frame:
line:     ServerMessage: Critical [20]: Invalid Token - Likely A timeout, please try again.
page: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
  
  
  <head>
    <title>Error!</title>
    <style type="text/css">
      #pageLogin
      {
        font-size: 10px;
        font-family: verdana;
        text-align: right;
      }
    </style>
    <style type="text/css" media="screen">
      @import "/static/css/style.css";
    </style>
  </head>
  <body>
    <div id="header">
      <div id="floatingTitle">
        <h1>Hardware : <script type="text/javascript" language="javascript">document.write(document.title);</script></h1>
        20 Wed Jan 20 21:16:10 2010
      </div>
    </div>
    <div id="main_content">
    ServerMessage: Critical [20]: Invalid Token - Likely A timeout, please try again.
      </div>
      <div id="footer">
        <!--
        <img src="/static/images/under_the_hood_blue.png" alt="TurboGears under the hood" />
        <p>TurboGears is a open source front-to-back web development
        framework written in Python</p>
        <p>Copyright &copy; 2006 Kevin Dangoor</p>
        -->
      </div>
    </body>
</html>

cmdline: /usr/bin/python /usr/bin/smoltSendProfile
component: smolt
executable: /usr/bin/smoltSendProfile
kernel: 2.6.31.9-174.fc12.i686.PAE
package: smolt-1.4-4.fc12
uuid: a5d27435
Comment 1 Jay Mist 2010-01-20 16:18:40 EST
Created attachment 385791 [details]
File: backtrace
Comment 2 Arne Chr. Jorgensen 2010-01-27 02:22:00 EST
Identical, but ..

package: smolt-gui-1.4-4.fc13
release: Fedora release 13 (Rawhide)

http://www.smolts.org/client/show/pub_4b07e672-4a86-44aa-921a-e2c373c96ca8
Comment 3 Jay Mist 2010-01-27 13:53:47 EST
Could submit Smolt data on subsequent attempt:

http://www.smolts.org/client/show/pub_943fc961-4f49-49a3-8bc1-d7a86e57ce3e
Comment 4 Jay Mist 2010-01-27 13:54:46 EST
Could submit Smolt data on subsequent attempt, may have been due to busy server.

http://www.smolts.org/client/show/pub_943fc961-4f49-49a3-8bc1-d7a86e57ce3e
Comment 5 Mike McGrath 2010-01-27 14:27:28 EST
It was, I'm going to close this bug.  There's two fixes I'm working on right now.  1) a better error message and 2) fixing the server.  2) is more long term.

Note You need to log in before you can comment on or make changes to this bug.