Bug 55770 - [RFE] A way to update hardware/distribution info in system profile
[RFE] A way to update hardware/distribution info in system profile
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-06 08:16 EST by Christian Rose
Modified: 2015-01-07 18:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-14 09:03:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2001-11-06 08:16:00 EST
Request
-------
Some sort of commandline option, similar to the package update option
in up2date, for updating the Red Hat Linux version and hardware
information in the RHN system profile, would be nice.

Rationale
---------
I'm not using rhnsd on my systems for various reasons, and update the
RHN package list by hand, every time after using rpm, with "up2date -p".

However, there seems to be no similar way to update the other profile
information. For example, I'd like to be able to update the Red Hat
Linux version registered in the RHN profile after doing an upgrade, or
update the hardware information registered in RHN after doing a hardware
upgrade. Maybe I didn't look close enough, but it seems this is
impossible to do with the client and impossible to do on the web site --
the only way I could accomplish getting the Red Hat Linux version and
hardware information updated in the profile was by actually deleting the
old profile and adding a new one.
Comment 1 Aleksey Nogin 2001-11-06 09:49:36 EST
One thing you can use is requesting a HW profile refresh at the web site and
then running rhn_check on the machine. But I agree that being able to do this in
*one* step from up2date could be nice...
Comment 2 Adrian Likins 2001-11-06 14:23:07 EST
Sounds like a good idea. I'll add it to the project plan.
Comment 3 Adrian Likins 2002-05-16 19:02:32 EDT
implemented in cvs
Comment 4 Jay Turner 2003-02-14 09:03:38 EST
All of the GUI configuration parameters are now available via commandline with
up2date-3.1.15-7.

Note You need to log in before you can comment on or make changes to this bug.