Bug 558048 - another rpmdiff
another rpmdiff
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-23 05:58 EST by Jens Petersen
Modified: 2010-01-23 09:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-23 07:33:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2010-01-23 05:58:03 EST
Description of problem:
I would like to package http://ftp.wl0.org/rpmdiff/
for fedora but the program name conflicts with rpmdiff from rpmlint...

Any suggestions on how to handle this:
I dunno how widely rpmlint's rpmdiff is used.
Personally I don't find the output so useful.
Comment 1 Ville Skyttä 2010-01-23 07:33:12 EST
rpmlint's rpmdiff has been around for $a_long_time, and is used for example AFAIK in some Fedora/Red Hat infrastructure and/or build systems (koji?).

Before packaging the rpmdiff you mentioned, I suggest taking a look at rpmdev-diff(1) from rpmdevtools, it has a similar feature set and more.  The only thing missing seems to be package metadata diffing, I'll look into adding that to rpmdev-diff.
Comment 2 Ville Skyttä 2010-01-23 09:01:08 EST
(In reply to comment #1)
> The only thing missing seems to be package metadata diffing, I'll look into
> adding that to rpmdev-diff.

http://git.fedoraproject.org/git/rpmdevtools.git?p=rpmdevtools.git;a=commitdiff;h=6027c6c180f2b3d7d952fcc17dd2d00b0eee30bf

Note You need to log in before you can comment on or make changes to this bug.