Bug 55811 - Bad french traduction
Bad french traduction
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-06 18:28 EST by LENHOF
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-16 07:10:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description LENHOF 2001-11-06 18:28:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
When selecting more than one file in nautilus the menu in Edit or the
context menu seems like this:
- Couper les fichiers
- Couper les fichiers
- Coller les fichiers

Instead of
- Couper les fichiers
- Copier les fichiers
- Coller les fichiers

When there's only one file selected the menu is good :
- Couper le fichier
- Copier le fichier
- Coller le fichier

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
As describe
	

Additional info:

The bug is display only...the action associated seems to be correct
Comment 1 Brent Fox 2002-09-17 17:49:34 EDT
Hm, well the original bug seems fixed in Null, but a new one has been introduced.  

Multiple selections now display (this looks correct):
- Couper les fichiers
- Couper les fichiers
- Coller les fichiers

But now a single file selection displays:
- Couper le fichier
- Copier le fichier
- Coller les fichiers (this one looks plural when it shouldn't be)
Comment 2 Brent Fox 2002-09-17 17:53:39 EDT
Actually, this looks true for English as well.  There appear to be some deeper
problems here.

When I select one file and click on the Edit menu, I see:
- Cut File
- Copy File
- Paste Files (grayed out because there's nothing in the clipboard)  I'm not
sure whether this should be plural or not since there's currently nothing in the
clipboard.

Anyway, I select a file and choose Edit -> Copy File.  Then I unselect the file
and go into another directory.  I now click Edit and the menu gives me the
option for "Paste Files".  It say "Paste File" since there's only one item in
the clipboard.  It should only say "Paste Files" if there's more than one item
in the clipboard.
Comment 3 Brent Fox 2002-09-17 17:54:38 EDT
Reassigning since this clearly isn't just a translation bug.
Comment 4 Brent Fox 2002-09-18 12:10:19 EDT
Personally, I think that the Edit menu should just read:
- Cut
- Copy
- Paste

This eliminates the problem of when to pluralize and when not to.  Also, saying
"Files" isn't always correct because it's possible to perform the actions on
directories as well, but the label doesn't change to say "Cut Directory".  It's
also possible to do a multiple selection on files and directories at the same
time, but it would be silly for the label to say "Cut Files and Directory"

It's much easier to just say Cut, Copy, and Paste.  Windows does it this way as
well.
Comment 5 Brent Fox 2002-09-18 17:20:39 EDT
I've submitted a patch to nautilus-list.  We'll see if they take it.
Comment 6 Alexander Larsson 2003-01-16 07:10:25 EST
Fixed in (at least) latest RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.