This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 558143 - Crashes when ejecting libmtp device
Crashes when ejecting libmtp device
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhythmbox (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Bastien Nocera
desktop-bugs@redhat.com
abrt_hash:6acc6f9e5380cd3fc1bace2a39e...
: Rebase
: 572335 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-23 16:55 EST by Matěj Cepl
Modified: 2010-11-15 09:44 EST (History)
4 users (show)

See Also:
Fixed In Version: rhythmbox-0.12.8-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 09:44:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (44.01 KB, text/plain)
2010-01-23 16:55 EST, Matěj Cepl
no flags Details
another backtrace (1.42 KB, text/plain)
2010-03-17 18:52 EDT, Matěj Cepl
no flags Details
another backtrace (4.66 KB, text/plain)
2010-03-17 18:52 EDT, Matěj Cepl
no flags Details
another backtrace (2.90 KB, text/plain)
2010-03-17 18:53 EDT, Matěj Cepl
no flags Details
another backtrace (2.49 KB, text/plain)
2010-03-17 18:53 EDT, Matěj Cepl
no flags Details
another output from rhythmbox -d (110.99 KB, text/plain)
2010-03-17 18:56 EDT, Matěj Cepl
no flags Details
another output from rhythmbox -d (2.14 MB, text/plain)
2010-03-17 18:56 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2010-01-23 16:55:44 EST
abrt 1.0.0 detected a crash.

How to reproduce
-----
1.connect Nokia E63 (in Music Player mode) to the computer via USB
2.do some copying back and forth
3.eject the USB connection (button in RB)

Attached file: backtrace
cmdline: rhythmbox
component: rhythmbox
executable: /usr/bin/rhythmbox
kernel: 2.6.32-8.el6.x86_64
package: rhythmbox-0.12.6-5.el6
rating: 4
reason: Process was terminated by signal 11
Comment 1 Matěj Cepl 2010-01-23 16:55:48 EST
Created attachment 386384 [details]
File: backtrace
Comment 3 RHEL Product and Program Management 2010-01-23 17:25:49 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Bastien Nocera 2010-02-15 10:47:25 EST
Either there's garbage in the MTP structures, or the transfer isn't actually finished.

Try reproducing the problem under valgrind, and please provide a rhythmbox debug log when reproducing.
Comment 5 Matěj Cepl 2010-03-10 16:34:27 EST
*** Bug 572335 has been marked as a duplicate of this bug. ***
Comment 6 Matěj Cepl 2010-03-17 18:52:40 EDT
Created attachment 400906 [details]
another backtrace
Comment 7 Matěj Cepl 2010-03-17 18:52:51 EDT
Created attachment 400907 [details]
another backtrace
Comment 8 Matěj Cepl 2010-03-17 18:53:01 EDT
Created attachment 400908 [details]
another backtrace
Comment 9 Matěj Cepl 2010-03-17 18:53:11 EDT
Created attachment 400909 [details]
another backtrace
Comment 10 Matěj Cepl 2010-03-17 18:56:00 EDT
Created attachment 400910 [details]
another output from rhythmbox -d
Comment 11 Matěj Cepl 2010-03-17 18:56:19 EDT
Created attachment 400911 [details]
another output from rhythmbox -d
Comment 12 Matěj Cepl 2010-03-17 19:09:09 EDT
I have tried couple of times to run

valgrind rhythmbox

and then

rhythmbox -d

and this is what I've got. Surprisingly, I am not able to reproduce the crash in the same manner as before (maybe it has something to do with abrt being broken on my computer, so I get only coredumps in my $HOME) -- rhythmbox window never went away completely. However, I've got these coredumps so something is crashing.

It might have something to do also with SELinux and bug 573588 (the promised update of selinux-policy still didn't make it into brew). However, all these tests were done with SELinux/Permissive, so it shouldn't affect the tests. Putting Dan on CC anyway, in case there is still something for him here.
Comment 13 Bastien Nocera 2010-06-01 14:31:57 EDT
LIBMTP PANIC: Could not open session! (Return code 765)
  Try to reset the device.
LIBMTP PANIC: Trying to get the error stack of a NULL device!
LIBMTP PANIC: Trying to clear the error stack of a NULL device!

Stupid library...
Comment 15 Bastien Nocera 2010-06-25 10:58:10 EDT
Intending to rebase to 0.12.8 + cherry-picks
Comment 17 Bastien Nocera 2010-06-25 13:15:26 EDT
Fixed in rhythmbox-0.12.8-1.el6
Comment 20 Matěj Cepl 2010-10-12 09:19:45 EDT
I don't have RHEL6 anymore, but I haven't seen this RB crash for some time already. Not that connecting to USB phone works, but at least it doesn't crash anymore.
Comment 22 releng-rhel@redhat.com 2010-11-15 09:44:08 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.