Bug 55819 - (DMI 440GX) RH 7.2 installation fails on Intel ISP2150
(DMI 440GX) RH 7.2 installation fails on Intel ISP2150
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-06 23:41 EST by spector
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description spector 2001-11-06 23:41:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010816

Description of problem:
RedHat 7.2 (and 7.1) completely fail when you try to intall on the Intel
ISP2150 platform (which is, according to the HCL a "RedHat Ready" system).
 Apparetnly either the kernel module for the AIC7XXX doesn't like this
Adaptec chips in the system or Anaconda is dying the true death.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start installation on an ISP2150
2.Hit ALT-F2 to look at kernel messages
3. See lots of SCSI but resets and timeouts, ad infinitum
	

Actual Results:  Tried installation several times... got really bummed out,
went got a few beers.  Tried again on several other ISP2150s with the same
results... got upset and considered switching to another Linux distribution.

Expected Results:  Linux should have installed without a hitch

Additional info:

This has been an outstanding problem since RH7.1  -- please get this
fixed!!!!!!!!!!!!!!!!!!
Comment 1 Brent Fox 2001-11-08 12:09:02 EST
This sounds like the kernel has a problem loading the module.  Changing components.
Comment 2 Arjan van de Ven 2001-11-08 12:20:44 EST
This machine has an 440GX chipset which, due to a bug in the Intel bios, doesn't
work out of the box.
Please try adding "apic" to the syslinux commandline.(eg type "linux apic" on
the very very first screen)

the official text agreed between Intel and Red Hat is:


Most implementations using the 440GX chipset require the "apic"
option to function correctly.  When this is the case, providing
DMI information to Red Hat as documented below[1] may allow us to
automate that setting in the future.

On some systems, the "apic" boot flag may not work.  Unfortunately,
because of Intel Proprietary information, these platforms are not
supported at this time.

[1] wget http://people.redhat.com/arjanv/dmidecode.c
    gcc dmidecode.c -o dmidecode
    ./dmidecode | \
       mail -s 'requires apic option to install' hardwarebugs-list@redhat.com
Comment 3 spector 2001-11-08 21:50:29 EST
The "linux apic" trick seems to have worked.  Thanks!

A side note, however, RedHat version 6.2 and 7.0 installed PERFECTLY on this 
same machine.  Out of exasperation I went and got a copyt of SuSE 7.3 Pro and 
it installed in a flash on the same machine without a single hiccup.  I have 
also installed SuSE and RH7.0 on dozens and dozens of other ISP2150s of 
varying vintages without a single other problem -- except where I have tried 
to install RH7.1 or RH72.

So.... I would suggest that blaming Intel for what is clearly a driver bug in 
the RedHat version of the aic7xxx drivers is, um, well, probably not what you 
really meant and borders on the disingenuous.
Comment 4 Arjan van de Ven 2001-11-09 03:16:16 EST
The fact that "apic" worked means it's NOT an aic7xxx driver bug.
We've talked LONG with intel about this and they admit it's a bios bug.

SuSE 7.3 works because they make "apic" the default, which we and they know will
break on other machines. If you sends me the output of dmidecode (see previous
comments on how) then your machine will work fine the next version as your bios
will then be added to the "known broken" list which has "apic" automatically.
Comment 5 Steve Kann 2001-11-20 19:03:19 EST
I have found this bug affects our 440GX mobo machine as well.  I'll run the
program and send ya the output as soon as it finishes installing.

It would be nice, though, to at least have some release notes about these kinds
of known issues, affecting very popular hardware, regardless of whose fault it
is.  Intel 440GX motherboards aren't exactly exotic stuff; they're still the
backbone of server farms everywhere.
Comment 6 Need Real Name 2002-05-19 08:57:51 EDT
RH 7.3 installation ALSO fails on Intel ISP2150

But this time it is even worse: it won't boot to the prompt where the apic
parameter could be passed to the kernel. It simply doesn't boot.



Comment 7 Arjan van de Ven 2002-06-04 10:02:06 EDT
sanmi@mediosav.com:
If you don't get to the syslinux screen it's not the kernel's fault, the kernel
isn't even loaded at that time; please file a separate bug against syslinux for
that.
Comment 8 Alan Cox 2003-06-07 16:37:23 EDT
Based on info we were finally able to extract from Intel most 440GX should work
with RH9.
If you have a board that doesnt please reopen the bug and also attach a
dmidecode dump
from it if you can
Comment 9 spector 2003-06-09 09:08:18 EDT
the stock RH9 boot CD fails on ISP2150 type machines unless you use "boot apic" at the SYSLINUX 
prompt.   Even once you build a system you must edit the grub command line to incude "apic 
init=/bin/init" in order to get the system to come up after instalation.
Comment 10 Alan Cox 2003-06-09 09:12:38 EDT
Can you run dmidecode on that system. It may be we need to add another bios
string to include it. Thanks
Comment 11 Arjan van de Ven 2003-06-09 09:36:45 EDT
and there is no apic commandline option anymore....
Comment 12 Bugzilla owner 2004-09-30 11:39:15 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.