Bug 55832 - Bad initial ramdisk images when using driver disks
Bad initial ramdisk images when using driver disks
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-07 09:04 EST by pdelaney
Modified: 2007-04-18 12:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-14 12:16:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pdelaney 2001-11-07 09:04:38 EST
Description of Problem:
Initial ramdisk images created when installations use a driver update disk 
may use obsolete object files (updated object files do not overwrite the 
obsolete object files) or are not created at all (entirely new driver), 
requiring the user to boot from floppy.

Version-Release number of selected component (if applicable):
Problem only appears with Red Hat 7.2 installer. 
Red Hat 7.1 and 7.0 installers work fine.

How Reproducible:
Always.

Steps to Reproduce:
1. Create a driver update disk for a new (unbundled) driver OR use a 
driver update disk for the LSI 929 (one can be supplied).
2. Create a boot disk during installation
3. 

Actual Results:
Installation completes successfully.
Reboot fails due to obsolete driver being loaded.
Boot from floppy disk created during installation is successful.  
  Once booted, re-creating the ramdisk images in /boot by running mkinitrd
  generates correct ramdisk images. System will now boot from the
  hard drive. 
   




Expected Results:
That the ramdisk images written in /boot would contain the updated object 
files stored in drivers/scsi. Instead, those ramdisk images were created 
using the obsolete images in drivers/message - resulting in boot failure.

Additional Information:
If an entirely new driver is loaded (one that is not bundled), the 
installer will not create the initial ramdisk images. 

We can provide a driver update disk for test and verification (or see Rob 
Landry who has a disk image). Hardware is available at Red Hat in the test 
lab.
Comment 1 Brent Fox 2001-11-08 22:55:46 EST
msw, are we running mkinitrd at the wrong time?
Comment 2 Jeremy Katz 2001-11-12 13:04:55 EST
We're not running mkinitrd, the kernel package is...  there's an update disk
which should fix the problem at
http://people.redhat.com/~tcallawa/dpt/images/updates-initrd.img, but
confirmation of this would be greatly appreciated.
Comment 3 pdelaney 2001-11-13 11:34:14 EST
Thanks!  I tested the updates-initrd.img found in the location above.  The 
installation worked just fine and reboot from the hard drive was successful. It 
appears that the bootloader attempted to install the driver twice - there were 
two calls to insmod and an error message produced - ERROR insmod module xxx 
already loaded - however the ramdisk images looked perfect and reboot (SMP and 
normal) was successful.
Comment 4 pdelaney 2001-11-13 11:45:18 EST
Took one more look at the ramdisk image. The script linuxrc calls the updated 
modules twice. This is a minor issue. Thanks again for updating anaconda.  
Contents of linuxrc:

!#/bin/nash

echo "Loading scsi_mod module"
insmod /lib/scsi_mod.o
echo "Loading sd_mod module"
insmod /lib/sd_mod.o
echo "Loading mptbase module"
insmod /lib/mptbase.o
echo "Loading mptbase module"
insmod /lib/mptbase.o
echo "Loading mptscsih module"
insmod /lib/mptscshi.o
echo "Loading mptscsih module"
insmod /lib/mptscsih.o


...

Comment 5 Jeremy Katz 2001-11-26 15:45:19 EST
Closing as fixed in rawhide
Comment 6 Tesfamariam Michael 2002-03-14 12:16:47 EST
Is it possible for this updates disk to arrange the scsi_hostadapter 
in /etc/modules.conf before making the initrd? When using various multiple scsi 
controllers during installation, RH7.2 installer doesn't order the modules 
in /etc/modules.conf properly. As a result, you get a kernel panic. Can the 
updates diskette order the scsi_hostadapter modules in /etc/modules.conf and 
then re-make the initrd?
Comment 7 Jeremy Katz 2002-03-14 12:32:47 EST
The updated boot disks released as errata in January fix the ordering issue

Note You need to log in before you can comment on or make changes to this bug.