Bug 558343 - Possibly insecure server configuration file permissions
Possibly insecure server configuration file permissions
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: krb5 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-24 19:50 EST by Daniel Qarras
Modified: 2010-01-25 11:58 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.7-23.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-25 11:58:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Qarras 2010-01-24 19:50:05 EST
Description of problem:
Permissions for kdc.conf and kadm.acl are 644 but since they contain somewhat sensitive data (esp. kadm.acl) I wonder wouldn't 600 would be more secure permissions?

Thanks.
Comment 1 Nalin Dahyabhai 2010-01-25 11:37:40 EST
You're not really supposed to let non-admins roam around on a KDC, but I don't see a lot of downside to making that change.

Note You need to log in before you can comment on or make changes to this bug.