Bug 558449 - smolt server reports false info
smolt server reports false info
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-25 07:15 EST by Arne Chr. Jorgensen
Modified: 2010-02-23 00:32 EST (History)
2 users (show)

See Also:
Fixed In Version: smolt-1.4.2-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-23 00:32:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot showing the false info (46.58 KB, image/png)
2010-01-25 07:15 EST, Arne Chr. Jorgensen
no flags Details

  None (edit)
Description Arne Chr. Jorgensen 2010-01-25 07:15:33 EST
Created attachment 386599 [details]
screenshot showing the false info

Description of problem:

See attached screen picture. 

- notice the info line at the bottom, which reports the chip correctly, while
it reports a different chip-version in the report-field.

( the same computer-model comes with different chips. Consider this to be importent enough to report )
 

Version-Release number of selected component (if applicable):
How reproducible:
Steps to Reproduce:
1.
2.
3.
Actual results:
Expected results:


Additional info:

- add a question:  the data generated does not reflect the truth as how many
computers there are. My own is reported at least 3 times as one change OS.
( not sure how this could be improved, but perhaps if asked, one could enter
the previous listed UUID )   

- some text field could be interesting in order to clarify parts that does not
work at all.
Comment 1 Mike McGrath 2010-01-25 10:51:04 EST
(In reply to comment #0)
> Created an attachment (id=386599) [details]
> screenshot showing the false info
> 
> Description of problem:
> 
> See attached screen picture. 
> 
> - notice the info line at the bottom, which reports the chip correctly, while
> it reports a different chip-version in the report-field.
> 

heh, I have no idea what is going on there, I'll take a look.

> ( the same computer-model comes with different chips. Consider this to be
> importent enough to report )
> 

> - add a question:  the data generated does not reflect the truth as how many
> computers there are. My own is reported at least 3 times as one change OS.
> ( not sure how this could be improved, but perhaps if asked, one could enter
> the previous listed UUID )   
> 

If you're doing upgrades, your UUID will stick.  If you aren't, you can always delete your old profile by running "smoltDeleteProfile" before you do a re-install.  Even if all that fails, for statistics we only consider 'active' statistics.  Those that have checked in during the last 90 days.

> - some text field could be interesting in order to clarify parts that does not
> work at all.    

That's what the wiki page is for.  You can do the ratings section to give a basic outlook at what happened, but the wiki page is more for a detailed "here's how it's broken" and "How to fix it" if you know.
Comment 2 Arne Chr. Jorgensen 2010-01-25 13:02:28 EST
Oh, I see. I didn't get the idea when I only found empty wiki-pages. 
>
> "here's how it's broken" and "How to fix it" if you know.
>
A "How to fix it" would have been - just the thing. The -if you know- part is troublesome ;)

( Suppose I have more then one entry because I change I swap disks and OS.)
Comment 3 Mike McGrath 2010-01-25 13:33:46 EST
Yeah, I've had marketing trouble with what to do about that.  The gui doesn't have this functionality yet but the CLI does if you run smoltSendProfile it'll scan and you'll get wiki links.  For example:

Scanning http://www.smolts.org/ for known errata.

        Errata Found!
                http://www.smolts.org/wiki/pci/1002/9598/1545/3994
                http://www.smolts.org/wiki/pci/1002/aa20/1545/aa20

And those are direct links to the wiki for hardware I've had problems with.  Perhaps I should spend some more time thinking about how to get the word out about all that.
Comment 4 Arne Chr. Jorgensen 2010-01-26 04:48:37 EST
I checked it out and found another error:

smoltSendProfile -p

I have really missed such a function as you cannot copy/paste anything
from the GUI. 

smoltSendProfile -d  would be nice if I could put in "view" option,
like 

smoltSendProfile -d -v 

( not knowing what the -p option would be like, but thinking -d may
add a level of details.)

Anyway "-p" option does not seem to work on x86_64 or i586
Comment 5 Mike McGrath 2010-01-26 09:10:29 EST
-p is fixed upstream but I've not pushed the release out yet, will be doing so this week.
Comment 6 Fedora Update System 2010-02-04 09:57:54 EST
smolt-1.4.2-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/smolt-1.4.2-1.fc12
Comment 7 Fedora Update System 2010-02-05 19:02:02 EST
smolt-1.4.2-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update smolt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1529
Comment 8 Fedora Update System 2010-02-23 00:31:42 EST
smolt-1.4.2-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.