Bug 558504 - gPXE used by KVM doesn't understand filename in DHCP option 67
gPXE used by KVM doesn't understand filename in DHCP option 67
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gpxe (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Matt Domsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-25 09:47 EST by Dan Horák
Modified: 2010-02-18 17:36 EST (History)
2 users (show)

See Also:
Fixed In Version: gpxe-0.9.9-1.20091018git.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-18 17:36:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2010-01-25 09:47:36 EST
Description of problem:
I am doing a PXE boot of KVM guest (Fedora 12) with PXE server driven by dnsmasq (Fedora 11). The issue is that gPXE understands filename option sent by BOOTP, but not in DHCP option 67.

Version-Release number of selected component (if applicable):
qemu-0.11.0-12.fc12.x86_64
gpxe-roms-qemu-0.9.7-6.fc12.noarch

Steps to Reproduce:
1. set boot type to PXE
2. start a guest
3. see non-successful attempts, press Ctrl+B
4. write "config" and see filename not set
  
Actual results:
filename not set

Expected results:
filename set


Additional info:
This issue was discussed with gPXE upstream at
http://markmail.org/message/jewjhsf62fq6a2nz#query:+page:1+mid:o64pdjcazm5bw5ej+state:results
Comment 1 Dan Horák 2010-01-25 09:54:50 EST
installing gpxe-0.9.9-1.20091018git.fc13 fixes the issue, so I think it worth to update the package in F-12 to the rawhide version
Comment 2 Fedora Update System 2010-01-25 10:47:48 EST
gpxe-0.9.9-1.20091018git.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gpxe-0.9.9-1.20091018git.fc12
Comment 3 Matt Domsch 2010-01-25 10:49:37 EST
ok, the gpxe from rawhide is now built for updates-testing. Please give it a try and vote up the karma.
Comment 4 Fedora Update System 2010-01-26 20:03:55 EST
gpxe-0.9.9-1.20091018git.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gpxe'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1085
Comment 5 Fedora Update System 2010-02-18 17:36:42 EST
gpxe-0.9.9-1.20091018git.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.