Bug 55884 - path directories problems with eCos Config
path directories problems with eCos Config
Status: CLOSED WONTFIX
Product: eCos
Classification: Retired
Component: ConfigTool (Show other bugs)
1.3.1
All Linux
medium Severity high
: ---
: ---
Assigned To: Julian Smart
Julian Smart
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-08 04:55 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-20 12:04:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-08 04:55:22 EST
Description of Problem:
Hi,
I'm new in eCos Config.
When I make library I have a problem with the path of the directories: the 
program builds the makefiles in this way (with a double slash):

export REPOSITORY := //C/eCos/eCos/packages
export PREFIX := //C/eCos/eCos/cross_arm_install



Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

This is the output that come out when I build library:
	
*** Process 1024 created "make -j1"
make -r -C hal/arm/arch/v1_3_1 headers
make[1]: Entering directory 
`/c/eCos/eCos/cross_arm_build/hal/arm/arch/v1_3_1'
makefile:91: //C/eCos/eCos/packages/pkgconf/rules.mak: No such host or 
network path
make[1]: stat://C/eCos/eCos/packages/pkgconf/rules.mak: No such host or 
network path
make[1]: *** No rule to make target 
`//C/eCos/eCos/packages/pkgconf/rules.mak'.  Stop.
make[1]: Leaving directory 
`/c/eCos/eCos/cross_arm_build/hal/arm/arch/v1_3_1'
make: *** [headers] Error 2

*** Process 1024 terminated (rc=2)
*** Killing process 1024 (TerminateProcess)
Comment 1 Need Real Name 2001-11-08 05:43:57 EST
I make a mistake, because the OS/Version it isn't Linux but is the packet 
"eCos Configuration Tool" under Windows.

Thank's a lot, Giuseppe Di Bona
Comment 2 Need Real Name 2001-11-15 05:37:33 EST
//c syntax is not supported by cygwin anymore. eCos config tool should be fixed 
to use /cygdrive/c or /c syntax instead.
The following section is extracted from the Cygwin's FAQ:

http://cygwin.com/faq/faq.html#SEC33
<<
Why doesn't //c (for C:) work anymore?
(Similarly for any drive letter, e.g. //z for Z:) 

This "feature" has long been deprecated, and no longer works at all in the 
latest release. As of release 1.3.3, //c now means the network share c. 

For a detailed discussion of why this change was made, and how deal with it 
now, refer to http://sources.redhat.com/ml/cygwin/2001-09/msg00014.html. 
>>
Comment 3 Alex Schuilenburg 2003-06-20 12:04:51 EDT
This bug has moved to http://bugs.ecos.sourceware.org/show_bug.cgi?id=55884

Note You need to log in before you can comment on or make changes to this bug.