Bug 56009 - rhn_register crashes after step 2
rhn_register crashes after step 2
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: rhn_register (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-10 10:09 EST by Eric Schaffner
Modified: 2015-01-07 18:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 12:37:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Schaffner 2001-11-10 10:09:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
rhn_register (gnome) and rhn_register --nox both crash after step 2. The
gnome version reports that the crash is due to python through the Gnome Bug
Buddy.  The CLI version of rhn_register crashes without any error message.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Start either rhn_register or rhn_register --nox
2.  Proceed to step 2, fill in the information requested
3.  rhn_register crashes
	

Actual Results:  When using the --nox flag, rhn_register does not give any
error messages.  When using the gnome version, rhn_register crashes with an
error in /usr/bin/python.  Here is the gdb output for this error in python:

(no debugging symbols found)...[New Thread 1024 (LWP 1367)]
0x4011e989 in __wait4 ()
   from /lib/i686/libc.so.6
#0  0x4011e989 in __wait4 () from /lib/i686/libc.so.6
#1  0x4019a534 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x400376f3 in waitpid (pid=1368, stat_loc=0xbfffd04c, options=0)
    at wrapsyscall.c:172
#3  0x407b2e88 in gnome_segv_handle () from /usr/lib/libgnomeui.so.32
#4  0x40035a85 in pthread_sighandler (signo=11, ctx=
      {gs = 7, __gsh = 0, fs = 0, __fsh = 0, es = 43, __esh = 0, ds = 43,
__dsh = 0, edi = 137988312, esi = 0, ebp = 3221214232, esp = 3221214188,
ebx = 134925400, edx = 1, ecx = 3619774181, eax = 1701716065, trapno = 14,
err = 4, eip = 1074703663, cs = 35, __csh = 0, eflags = 2163202,
esp_at_signal = 3221214188, ss = 43, __ssh = 0, fpstate = 0xbfffd170,
oldmask = 2147483648, cr2 = 1701716065})
    at signals.c:97
#5  <signal handler called>
#6  0x400ead2f in strlen () from /lib/i686/libc.so.6
#7  0x0807e60d in PyString_FromString () at eval.c:41
#8  0x409b84b8 in dmi_table () from /usr/share/rhn/register/dmimodule.so
#9  0x080a39a0 in PyDict_Type () at eval.c:41


Expected Results:  rhn_register should have proceeded to step 3.

Additional info:

rhn_register-2.7.2-7.x.2
python-1.5.2-35
gnome-libs-1.2.13-16
Comment 1 apost 2002-06-25 15:03:22 EDT
I have the exact same problem. I'm running RedHat 7.2 on a 300 MHz Pentium II with 
192MB of RAM, and the python interpreter crashes after Step 2. I have rhn_register-
2.7.9-7.x.2. I tracked the crash to /usr/share/rhn/register/hardware.py, line 266 (line that 
crashes is commented below):

def read_dmi():
    uname = string.lower(os.uname()[4])
    dmidict = {}
    if not uname[0] == "i" or not uname[-2:] == "86":
        return {}
    # Looks like IA32, try reading dmi
    try:
        import dmi
    except:
        return {}
    # Now try to parse DMI
    try:
        d = dmi.DMI() #!!!CRASH IS HERE!!!

Replacing the offending line with "return {}" made the problem go away and allowed me 
to register.

Andrew
Comment 2 Bill Nottingham 2006-08-07 15:14:29 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 3 Bill Nottingham 2006-10-18 12:37:50 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.