Bug 560151 - LLVM package should build llvm-apidoc by default
LLVM package should build llvm-apidoc by default
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-29 19:28 EST by Eric Smith
Modified: 2010-05-26 15:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-24 09:25:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Smith 2010-01-29 19:28:33 EST
Description of problem:

The llvm package as built in Fedora does not include the doxygen documentation for llvm developers.  The spec file says that it is by default not built because it is large.  I don't think this is a reasonable justification for omitting it, as developers need it.  If the -devel subpackage is included in Fedora, the -apidoc subpackage should be included as well.

Version-Release number of selected component (if applicable):
llvm-2.6-0.5.pre1.fc12

How reproducible:
100%

Steps to Reproduce:
1.  none required, repository does not contain llvm-apidoc
  
Actual results:
repository does not contain llvm-apidoc

Expected results:
repository should contain llvm-apidoc, or alternatively, the documentation should be included in the -devel subpackage.

Additional info:
Comment 1 Michel Alexandre Salim 2010-05-24 09:25:47 EDT
apidoc has been turned on in Rawhide. The recommended LLVM build process (of having the output directory be separate from the source directory) does not work when doxygen *and* clang are both enabled -- the doxygen sources are not copied properly -- so I've reverted to building within the source directory as per normal
Comment 2 Michel Alexandre Salim 2010-05-26 15:08:14 EDT
It's been pointed out on the development list that the apidocs generated are indeed unreasonably huge; I've reverted them to disabled by default in 2.7-3.

I have, however, made sure that --with apidoc now actually works. There was a problem building the clang apidocs if the build is done from a directory other than the source root -- even though this was upstream recommendation.

You can still regenerate them yourself (rpmbuild --with apidoc llvm-2.7-3.fc14.src.rpm) , or view the API documentation on LLVM's site.

Note You need to log in before you can comment on or make changes to this bug.