Bug 56020 - cpanflute uses "invalid" group Applications/CPAN
Summary: cpanflute uses "invalid" group Applications/CPAN
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-10 23:46 UTC by Aleksey Nogin
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-10 23:47:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aleksey Nogin 2001-11-10 23:46:58 UTC
/usr/lib/rpm/cpanflute creates a .spec file with "Group:
Applications/CPAN". However according to /usr/share/doc/rpm-4.0.3/GROUPS
this is not a valid group.

Among other things, this creates problems when a cpanflute-based package is
checked for validity by some system that insists on having a "legal" group
(such as, for example, http://rhcontrib.bero.org/ ).

Comment 1 Jeff Johnson 2001-11-15 23:52:20 UTC
So edit cpanflute. The fix -- if necessary -- will be
to remove cpanflute from rpm, as it's usefulness has come and gone.

Comment 2 Aleksey Nogin 2001-11-16 16:46:27 UTC
By why not change cpanflute so that future releases of rpm-build do not have
this problem?

Comment 3 Jeff Johnson 2001-11-16 16:57:57 UTC
Because the value of the Group: field that should be
used is a Red Hat distro problem, not an rpm problem,
and so cannot be solved in rpm source code.


Note You need to log in before you can comment on or make changes to this bug.