Bug 56033 - make xconfig with Kernel package 2.4.9-7 fails
make xconfig with Kernel package 2.4.9-7 fails
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-11 09:50 EST by Quentin Gunn
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-11 09:50:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Quentin Gunn 2001-11-11 09:50:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.13 i686)

Description of problem:
Make xconfig will not run with the i686 template in /usr/src/linux/configs.
It seems to have 3 problem areas. 
1) syntax error in drivers/net/Config.in
2) syntax errors in drivers/addons/Config.in (Can't handle
dep_bool/dep_mbool/dep_tristate condition
3) Binary emulation of other binary systems.. Mode svr4 seems to not
compile due to 
an defined component being called. Need seperate bug report if that helps.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install rpms for kernel 2.4.9-7. I installed headers/i686 and source
2.copy from /usr/src/linux-2.4.9-7/configs the kernel-2.4.9-7 config to
.config in /usr/src/linux
3.run make xconfig
4. Correct drivers/net/Config.in on line 278. The last p in config_pp is
wrapped on next
line.
5. Correct drivers/addon/Config.in. Line 7,8 & 9. Changed dep_tristate to
tristate. I sitched these to "n" in the gui
6. Disabled the SVR3/SVR4 option in Binary emulation of other binary
systems.
At last the compile runs.
	

Actual Results:  Eventually the kernel compile was successful after
following the above steps

Additional info:
Comment 1 Arjan van de Ven 2001-11-11 09:57:20 EST
This is supposed to be fixed in 2.4.9-13 as released 2 weeks ago ;(
Comment 2 Quentin Gunn 2001-11-11 10:10:11 EST
This fix is not available through your errata, general advisories.
Comment 3 Arjan van de Ven 2001-11-11 10:14:23 EST
It better be.... and it's listed in the 7.2 errata list on www.redhat.com/support
and is also available via up2date (I know, I just upgraded my last machine).

See

http://www.redhat.com/support/errata/RHSA-2001-142.html

If any of the files are missing on your mirror, please inform us which mirror so
we can contact the admin of that mirror.
Comment 4 Quentin Gunn 2001-11-11 21:40:58 EST
Yepp it seems some of the mirrors might not be carrying the latest and greatest.
I tried
ftp://ftp.de.uu.net/pub/linux/redhat/updates/7.2/en/os/i686/
I see in i686 
[BINARY]     glibc-2.2.4-19.i686.rpm. . . . . . . . .    [Oct 22 01:20]      5M
[BINARY]     kernel-2.4.9-7.i686.rpm. . . . . . . . .    [Oct 22 10:32]      9M
[BINARY]     kernel-enterprise-2.4.9-7.i686.rpm . . .    [Oct 22 10:33]     10M
[BINARY]     kernel-smp-2.4.9-7.i686.rpm. . . . . . .    [Oct 22 10:30]     10M
and in i386
[BINARY]     kernel-2.4.9-7.i386.rpm. . . . . . . . .    [Oct 22 10:33]      9M
[BINARY]     kernel-BOOT-2.4.9-7.i386.rpm . . . . . .    [Oct 22 10:30]      3M
[BINARY]     kernel-doc-2.4.9-7.i386.rpm. . . . . . .    [Oct 22 10:32]      1M
[BINARY]     kernel-headers-2.4.9-7.i386.rpm. . . . .    [Oct 22 10:34]      1M
[BINARY]     kernel-source-2.4.9-7.i386.rpm . . . . .    [Oct 22 10:32]     23M
Normally I use the imperial college mirror and I see that is upto date. Sorry.
By the way. The following site in the UK seems not quite right.. Could you
please report this too.
ftp://sunsite.org.uk/Mirrors/ftp.redhat.com/pub/redhat/updates. It belongs to
sunsite.org.uk

Note You need to log in before you can comment on or make changes to this bug.