Bug 560482 - [abrt] crash in thunderbird-3.0.1-1.fc12
Summary: [abrt] crash in thunderbird-3.0.1-1.fc12
Keywords:
Status: CLOSED DUPLICATE of bug 551907
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3075b6c877c1fed45e879da7ff2...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-31 22:21 UTC by Ryan Spinuzzi
Modified: 2010-02-04 02:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-04 02:52:37 UTC


Attachments (Terms of Use)
File: backtrace (175.01 KB, text/plain)
2010-01-31 22:21 UTC, Ryan Spinuzzi
no flags Details

Description Ryan Spinuzzi 2010-01-31 22:21:11 UTC
abrt 1.0.4 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/thunderbird-3.0/thunderbird-bin
comment: What else can I install as far as debuging info for the shared libs.  It says missining debuginfo for shared libs.
component: thunderbird
executable: /usr/lib64/thunderbird-3.0/thunderbird-bin
kernel: 2.6.31.12-174.2.3.fc12.x86_64
package: thunderbird-3.0.1-1.fc12
rating: 4
reason: Process was terminated by signal 11 (Segmentation fault)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1.  I checked my mailboxes for new mail by using ctrl shift T.
2.  Then thunderbird crashed.
3.

Comment 1 Ryan Spinuzzi 2010-01-31 22:21:18 UTC
Created attachment 387897 [details]
File: backtrace

Comment 2 Chris Campbell 2010-02-04 02:51:04 UTC
#2  <signal handler called>
No symbol table info available.
#3  NameAtom (aContent=0x0) at ../../../dist/include/content/nsINodeInfo.h:110
No locals.
#4  Tag (aContent=0x0) at ../../../dist/include/content/nsIContent.h:218
No locals.
#5  nsTextServicesDocument::IsBlockNode (aContent=0x0)
    at /usr/src/debug/thunderbird-3.0.1/comm-1.9.1/mozilla/editor/txtsvc/src/nsTextServicesDocument.cpp:3095
        atom = <value optimized out>
#6  0x00007f271519f4f1 in nsTextServicesDocument::FirstTextNodeInNextBlock (
    aIterator=0x7f2706b3e5f0)
    at /usr/src/debug/thunderbird-3.0.1/comm-1.9.1/mozilla/editor/txtsvc/src/nsTextServicesDocument.cpp:4263
        content = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
        prev = {<nsCOMPtr_base> = {mRawPtr = 
    0x7f27059308d0}, <No data fields>}
        crossedBlockBoundary = 0
#7  0x00007f271519f5af in nsTextServicesDocument::GetFirstTextNodeInNextBlock
    (this=0x7f27069ec480, aContent=0x7f27069ec4b8)
    at /usr/src/debug/thunderbird-3.0.1/comm-1.9.1/mozilla/editor/txtsvc/src/nsTextServicesDocument.cpp:4325
        result = <value optimized out>
        node = 0x7f27059308d0
#8  0x00007f271a556df8 in mozSpellChecker::Replace (this=0x7f27059806b0, 
    aOldWord=..., aNewWord=..., aAllOccurrences=<value optimized out>)
    at /usr/src/debug/thunderbird-3.0.1/comm-1.9.1/mozilla/extensions/spellcheck/src/mozSpellChecker.cpp:223
        selOffset = 163
        currentBlock = 1
        begin = -1
        end = -1
        done = 1
        str = {<nsFixedString> = {<nsString> = {<nsAString_internal> = {
                mData = 0x37d368bc74, mLength = 0, mFlags = 
    65537}, <No data fields>}, mFixedCapacity = 63, mFixedBuf = 
    0x7fff47337830}, mStorage = {0, 18227, 32767, 0, 39473, 6306, 32551, 0, 
    30944, 18227, 32767, 0, 49040, 14810, 40912, 49116, 30944, 18227, 32767, 
    0, 0, 0, 0, 0, 32208, 18227, 32767, 0, 30064, 8545, 32551, 0, 31928, 
    18227, 32767, 0, 8320, 3464, 32551, 0, 25015, 54119, 55, 0, 31136, 18227, 
    32767, 0, 0, 0, 0, 0, 25049, 54119, 55, 0, 18736, 6346, 32551, 0, 31568, 
    18227, 32767, 0}}
        startBlock = 0
        currOffset = 0
        result = <value optimized out>
        newWord = {<nsFixedString> = {<nsString> = {<nsAString_internal> = {
                mData = 0x7fff473378d0, mLength = 7, mFlags = 
    65553}, <No data fields>}, mFixedCapacity = 63, mFixedBuf = 
    0x7fff473378d0}, mStorage = {98, 101, 99, 97, 117, 115, 101, 0, 1080, 
    54156, 55, 0, 41576, 8559, 32551, 0, 1, 0, 0, 0, 59216, 8594, 32551, 0, 
    2, 0, 0, 0, 31344, 18227, 32767, 0, 0, 0, 0, 0, 27958, 64, 0, 0, 64528, 
    1799, 32551, 0, 40, 0, 0, 0, 0, 0, 0, 0, 49056, 3131, 32551, 0, 1, 0, 0, 
    0, 35542, 64, 0, 0}}




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Chris Campbell 2010-02-04 02:52:37 UTC
Thank you for taking the time to submit this bug report.

This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 551907 ***


Note You need to log in before you can comment on or make changes to this bug.