Bug 56055 - "unhandled exception has occured"
"unhandled exception has occured"
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-11 22:28 EST by Dennis DeBruler
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-15 04:59:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis DeBruler 2001-11-11 22:28:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4)
Gecko/20011019 Netscape6/6.2

Description of problem:
crash occurs near the end of installing packages. How many floppies should
I need for the crash dump? It kept telling me to insert a floppy, but it
never wrote very much.

Trace back is:

File "/usr/bin/anaconda", line 620, in ? inf.run(id, dispatch, configFileDqta)
File "/usr/lib/anaconda/text.ph", line 408, in run dispatch.gotoNext()

I am trying to install a "small" system on a HP VE 5/75 to be a home
router. It has 2 3c509 ethernet cards, 32M of RAM, and a 502M disk drive.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. The autopartitioning refused to use such a "small" drive. (Linux has
bloated. I remember when 0.5G was a big drive.) I used druid to use 21M for
/boot, 64M for swap, and the rest for /.
2. Unfortunately, I don't know how to get a list of the packages I was
trying to install. I turned off the X and Gnome/KDI stuff. I turned on the
routing and emacs package groups.


Actual Results:   It fails during the emacs package at 332M of 361M. The /
partition is about 450M.

Expected Results:  The package should have installed. Is there a big
intermediate uncompressed file that won't fit? Maybe it is time to learn jove.
No way am I going to learn vi.

Additional info:
Comment 1 Dennis DeBruler 2001-11-11 22:41:56 EST
Trying it again with out emacs, I noticed that / has only 418M. I forgot that I
had cranked up the swap space from 32M to 64M.
Comment 2 Dennis DeBruler 2001-11-12 06:13:34 EST
Yep. I think the problem was not enough room for intermediate files. The fix is
to generate a decent error message. Instead of telling me to file a bug report,
tell me that there is not enough room to install a package and the name of the
package. Give me the option of continuing the install without said package. It
would have been a lot easier adding the jed package after the install rather
then filling out the druid form over and over.

BTW, autopartition should not refuse to partition the disk. Instead, it should
pop up a warning that my / partition is only <whatever> and that <?> is the
recommended minimum.

Why does anaconda need several 10s of millions of bytes of intermediate storage?
The next install failed with only 3M left to go while installing jed using just
the group level selections except for Applicaiton/Editors. The next iteration I
went through all of the packages and removed the ISDN package and the stuff that
needed PYTHON. A df -k of / ends up less than half full: 190279 used of 415361.

(My first Linux install was a Slackware distribution from a few boxes of
floppies. Back then, I think a 200M drive was considered too small and 500M was
considered bleeding edge big.)
Comment 3 Jeremy Katz 2001-12-12 15:41:46 EST
What type of install is this on?
Comment 4 Dennis DeBruler 2001-12-14 21:41:58 EST
custom
Comment 5 Need Real Name 2002-01-03 12:44:35 EST
If this fails at emacs install, check out bug # 57842
Comment 6 Jeremy Katz 2002-01-21 01:02:52 EST
What install medium are you using (cdrom, ftp, etc)?
Comment 7 Dennis DeBruler 2002-01-21 17:24:41 EST
cdrom

I haven't looked at 57842, but this problem is not unique to emacs. emacs may
tend to trip it because it is a big package.
Comment 8 Brent Fox 2002-01-24 23:11:06 EST
It sounds possible that the cdrom is damaged somehow.  When the crash happens,
press <Ctrl><Alt><F4>.  Do you see any messages that look related to the cdrom
drive?  Specifically, look for messages that say something about sectors or seek
errors.  For example:
<4>end_request: I/O error, dev 16:00 (hdc), sector 936056
<4>hdc: cdrom_decode_status: status=0x51 { DriveReady SeekComplete Error }
<4>hdc: cdrom_decode_status: error=0x34
<4>hdc: cdrom_decode_status: status=0x51 { DriveReady SeekComplete Error }
<4>hdc: cdrom_decode_status: error=0x34
<4>hdc: cdrom_decode_status: status=0x51 { DriveReady SeekComplete Error }
<4>hdc: cdrom_decode_status: error=0x34


Do you see anything like this?
Comment 9 Dennis DeBruler 2002-02-15 04:59:14 EST
Sorry about the delay, but I would have to dig that computer out of a pile and
reinstall to look at the log. But then it occurred to me that I have since built
a new computer and loaded everything on it from the same CD-ROMs with no
problem. In fact, I did an "everything" install a couple of times without
problems. So I think the media itself is OK.
Comment 10 Jeremy Katz 2002-02-19 18:29:32 EST
Maybe a bad CD / media interaction.  Without more information, that's the
assumption I'm going on (because if it were really something else, I'd expect to
see it in my testing or a lot more in bugzilla)

Note You need to log in before you can comment on or make changes to this bug.