Bug 56077 - [1.5.24-22] doesn't rebuild in current environment (autoconf 2.5x, gcc 3.1)
[1.5.24-22] doesn't rebuild in current environment (autoconf 2.5x, gcc 3.1)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: cyrus-sasl (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-12 11:41 EST by Bernhard Rosenkraenzer
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.5.24-24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-08 09:33:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Rosenkraenzer 2001-11-12 11:41:51 EST
Probably a missing include, quite likely caused by an autoconf 
incompatibility:

gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include -I/usr/local/include 
-I/usr/kerberos/include -Wall -W -O2 -march=i386 -mcpu=i686 -fPIC -c 
checkpw.c  -fPIC -DPIC
cc1: warning: changing search order for system directory 
"/usr/local/include"
cc1: warning:   as it has already been specified as a non-system directory
checkpw.c: In function `shadow_verify_password':
checkpw.c:360: warning: implicit declaration of function `getspnam'
checkpw.c:360: warning: assignment makes pointer from integer without a 
cast
checkpw.c:363: dereferencing pointer to incomplete type
checkpw.c:364: warning: implicit declaration of function `crypt'
checkpw.c:364: warning: assignment makes pointer from integer without a 
cast
checkpw.c:365: dereferencing pointer to incomplete type
[...]

Also, -I/usr/local/include should be removed from CFLAGS.
Comment 1 Bill Nottingham 2006-08-07 22:06:56 EDT
'Red Hat Raw Hide' refers to the development tree for Red Hat Linux.
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues were not resolved in a more
timely manner. However, we do want to make sure that important 
don't slip through the cracks. If these issues are still present
in a current release, such as Fedora Core 5, please move these
bugs to that product and version. Note that any remaining Red Hat
Raw Hide bugs will be closed as 'CANTFIX' on September 30, 2006.
Thanks again for your help.

Note You need to log in before you can comment on or make changes to this bug.