Bug 561021 - [abrt] crash in ruby-
[abrt] crash in ruby-
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2010-02-02 09:14 EST by Glen Fullmer
Modified: 2010-12-03 18:26 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-12-03 18:26:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
File: backtrace (79.37 KB, text/plain)
2010-02-02 09:14 EST, Glen Fullmer
no flags Details
Ruby code (4.62 KB, text/plain)
2010-05-14 20:23 EDT, Glen Fullmer
no flags Details

  None (edit)
Description Glen Fullmer 2010-02-02 09:14:20 EST
abrt 1.0.4 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: ruby ../getPics.rb http://www.meetup.com/Singlesingilbert/
comment: Ran a program that checks pictures on a meetup.com web site.  There are a lot of files > 25,000.  It doesn't download them unless I don't have them already, and in this case it didn't download any new files, but is building a metadatafile that has information about each of the picture.  I am a new Ruby programmer, so there might be something in the code that caused this, but it shouldn't do a hard crash in glib, should it?  There was a memory leak problem that I thought I solved by "objectifying" the program, and it stopped swapping to death and now it just crashes.
component: ruby
executable: /usr/bin/ruby
package: ruby-
rating: 4
reason: Process was terminated by signal 6 (Aborted)
release: Fedora release 12 (Constantine)

How to reproduce
1. I am not sure although with this program it is repeatable after a long series of web "scraping loops".
2. However, it doesn't always crash in the same place.
Comment 1 Glen Fullmer 2010-02-02 09:14:25 EST
Created attachment 388308 [details]
File: backtrace
Comment 2 Mamoru TASAKA 2010-05-14 15:44:26 EDT
Would you attach getPics.rb here?
Comment 3 Glen Fullmer 2010-05-14 20:23:11 EDT
Created attachment 414193 [details]
Ruby code
Comment 4 Mamoru TASAKA 2010-05-15 02:33:46 EDT
(In reply to comment #3)
> Created an attachment (id=414193) [details]
> Ruby code    

I tried ruby ./getPics.rb Singlesingilbert using this script
but crash does not occur. Would you try again using the this
ruby rpm?
Since 1.8.6p399 has some fix for gc related bug and -3 has
a fix for null class issue, using this ruby may fix the issue
you saw.

If this issue seems still reproducible, I would appreciate it
if you would attach the new gdb backtrace.
Comment 5 Bug Zapper 2010-11-03 19:15:37 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 6 Bug Zapper 2010-12-03 18:26:15 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.