Bug 561023 - needs-restarting always displays "Loaded plugins: presto"
needs-restarting always displays "Loaded plugins: presto"
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-02 09:21 EST by Till Maas
Modified: 2014-01-21 18:13 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-02 12:17:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2010-02-02 09:21:20 EST
Description of problem:
needs-restarting always displays "Loaded plugins: presto", which seems to be unecessary, because one cannot configure which plugins are used. Also it is the only output, if there is nothing to report.

Version-Release number of selected component (if applicable):
yum-utils-1.1.25-1.fc12

How reproducible:
always

Steps to Reproduce:
0. Optional: reboot the system
1. LANG=C needs-restarting

Actual results:
Loaded plugins: presto

Expected results:
nothing
Comment 1 seth vidal 2010-02-02 12:17:27 EST
nod - 
I've added a patch upstream to disable plugins for need-restarting.
Comment 2 Till Maas 2010-02-02 13:00:24 EST
(In reply to comment #1)
> nod - 
> I've added a patch upstream to disable plugins for need-restarting.    

just FYI: it already disabled two plugins, e.g. yum displays on the same system that it uses these plugins:
Loaded plugins: downloadonly, presto, security
Comment 3 seth vidal 2010-02-02 13:59:35 EST
downloadonly and security only get involved if you setup the interface of yum, not just the base object.

So it is not that is not disabling them, it's just not ever using them.

Note You need to log in before you can comment on or make changes to this bug.