Bug 561089 - editing text file with gedit seriously destroys the file
editing text file with gedit seriously destroys the file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-02 11:55 EST by Mamoru TASAKA
Modified: 2010-04-10 05:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-10 05:06:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
original xscreensaver.spec file (48.56 KB, text/plain)
2010-02-02 11:56 EST, Mamoru TASAKA
no flags Details
xscreensaver.spec with edited by gedit (56.00 KB, text/plain)
2010-02-02 11:56 EST, Mamoru TASAKA
no flags Details
strace log (1.15 MB, text/plain)
2010-02-28 13:51 EST, Mamoru TASAKA
no flags Details

  None (edit)
Description Mamoru TASAKA 2010-02-02 11:55:15 EST
Description of problem:
Well, as shown in the summary editing text file
with gedit seriously destroys the file...

Version-Release number of selected component (if applicable):
gedit-2.29.5-1.fc13.i686

How reproducible:
Currently 100%

Steps to Reproduce:
1. Download rawhide xscreensaver.spec (from Fedora CVS, for example)
2. open xscreensaver.spec with $ gedit xscreensaver.spec $
3. At the top of gedit window, type return key
4. type Ctrl-S and save the document
  
Actual results:
See the attached.

Expected results:


Additional info:
I did not see this issue yesterday, so this may be due to
some other component.
Comment 1 Mamoru TASAKA 2010-02-02 11:56:14 EST
Created attachment 388349 [details]
original xscreensaver.spec file
Comment 2 Mamoru TASAKA 2010-02-02 11:56:49 EST
Created attachment 388350 [details]
xscreensaver.spec with edited by gedit
Comment 3 Mamoru TASAKA 2010-02-08 11:07:39 EST
2.28.3 does not seem to reproduce this issue.
Still reproducible with 2.29.5
Comment 4 Mamoru TASAKA 2010-02-12 07:42:24 EST
Still seeing this problem with 2.29.6-1.fc13
Comment 5 Matthias Clasen 2010-02-14 16:50:36 EST
I cannot reproduce this here.
Comment 6 Mamoru TASAKA 2010-02-15 11:01:20 EST
Unfortunately still reproducible... with gedit-2.29.6-1.fc13.i686
Not reproducible with gedit-2.28.3-1.fc12.i686
Comment 7 Matthias Clasen 2010-02-26 20:46:34 EST
I am still not able to reproduce. Anything different on your system, e.g. using a non-UTF-8 locale, or something like that ?
Comment 8 Mamoru TASAKA 2010-02-28 13:46:38 EST
I am using LANG=ja_JP.UTF-8, however even if I set LANG=C on
uxterm this seems reproducible.
Comment 9 Mamoru TASAKA 2010-02-28 13:51:38 EST
Created attachment 396893 [details]
strace log

Well, I don't know if this is useful or not, however I will
attach strace log with

- $ script strace.log
- $ strace gedit xscreensaver.spec
- On launched gedit, just
  * type return key
  * type backspace key
  * type ctrl-s
  * type ctrl-q
- $ exit
Comment 10 Bug Zapper 2010-03-15 10:21:18 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Mamoru TASAKA 2010-03-17 02:21:07 EDT
gedit-2.29.8-2.fc13.i686 still reproduces this issue.
Comment 12 Mamoru TASAKA 2010-04-10 05:06:09 EDT
I tried 2.30.0-1.fc13 for a day and it issue seems no
longer reproducible. Once closing.

Note You need to log in before you can comment on or make changes to this bug.