This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 561176 - SELinux is preventing /usr/bin/pulseaudio "read" access on \x2fdevices\x2fpci0000:00\x2f0000:00:14.2\x2fsound\x2fcard0.
SELinux is preventing /usr/bin/pulseaudio "read" access on \x2fdevices\x2fpci...
Status: CLOSED DUPLICATE of bug 573164
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:1e11644cc58...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-02 17:57 EST by dvdriddell
Modified: 2010-03-24 09:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-24 09:18:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dvdriddell 2010-02-02 17:57:47 EST
Summary:

SELinux is preventing /usr/bin/pulseaudio "read" access on
\x2fdevices\x2fpci0000:00\x2f0000:00:14.2\x2fsound\x2fcard0.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by pulseaudio. It is not expected that this
access is required by pulseaudio and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:device_t:s0
Target Objects                \x2fdevices\x2fpci0000:00\x2f0000:00:14.2\x2fsound
                              \x2fcard0 [ file ]
Source                        pulseaudio
Source Path                   /usr/bin/pulseaudio
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           pulseaudio-0.9.21-4.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-78.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.7-37.fc12.x86_64 #1 SMP
                              Fri Jan 29 14:19:39 UTC 2010 x86_64 x86_64
Alert Count                   2
First Seen                    Tue 02 Feb 2010 09:40:19 PM GMT
Last Seen                     Tue 02 Feb 2010 09:40:19 PM GMT
Local ID                      3e411e4e-7d8a-4494-9064-541cc22ba753
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1265146819.402:42): avc:  denied  { read } for  pid=2964 comm="pulseaudio" name="\x2fdevices\x2fpci0000:00\x2f0000:00:14.2\x2fsound\x2fcard0" dev=devtmpfs ino=12515 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1265146819.402:42): avc:  denied  { open } for  pid=2964 comm="pulseaudio" name="\x2fdevices\x2fpci0000:00\x2f0000:00:14.2\x2fsound\x2fcard0" dev=devtmpfs ino=12515 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:device_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1265146819.402:42): arch=c000003e syscall=2 success=yes exit=14 a0=7fff55acbd60 a1=0 a2=1b6 a3=0 items=0 ppid=2962 pid=2964 auid=4294967295 uid=42 gid=473 euid=42 suid=42 fsuid=42 egid=473 sgid=473 fsgid=473 tty=(none) ses=4294967295 comm="pulseaudio" exe="/usr/bin/pulseaudio" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-78.fc12,catchall,pulseaudio,xdm_t,device_t,file,read
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t device_t:file { read open };
Comment 1 Daniel Walsh 2010-02-03 08:11:42 EST
This is a problem in udev or some other process creating files under /dev.
You have a mislabeled /dev/.udev

restorecon -R -v /dev/.udev
Comment 2 Harald Hoyer 2010-03-24 09:18:37 EDT

*** This bug has been marked as a duplicate of bug 573164 ***

Note You need to log in before you can comment on or make changes to this bug.