Bug 56139 - up2date complains about invalid server certificate
up2date complains about invalid server certificate
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-13 02:18 EST by Jan Rossmann
Modified: 2015-01-07 18:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-27 10:08:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Rossmann 2001-11-13 02:18:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-13custom i686)

Description of problem:
when starting up2date I get the message:
Error Class Code 9
Error Class Info: Invalid server certificate

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start up2date as root
2.
3.
	

Actual Results:  PopUp with the error message

Expected Results:  Window to update system

Additional info:
Comment 1 albryan 2001-11-13 16:03:20 EST
I have this problem too. I am using an updated kernel from rawhide.
Comment 2 Adrian Likins 2001-11-13 18:59:02 EST
Invalid server certificate almost always indicates that the client is
pointing at the wrong server.

Were these updates from beta releases?

Verify that the "serverURL" config setting is 
https://www.rhns.redhat.com/XMLRPC

in both:

/etc/sysconfig/rhn/up2date
/etc/sysconfig/rhn/rhn_register
Comment 3 Jan Rossmann 2001-11-14 01:59:23 EST
I checked the Server config.
Originally I had noSSLServerURL=http://www.rhns.redhat.com/XMLRPC/
I changed it to SSLServerURL=https://www.rhns.redhat.com/XMLRPC

but I still get the same result.

Im using a Proxy, could that cause the problem?
Comment 4 Adrian Likins 2002-03-26 19:04:37 EST
If your using a http proxy, you need to configure it.

If your still getting invalid server certificate issues, more
than likely you have an improper cert. Perhaps one registered
against the beta servers?
Comment 5 Jan Rossmann 2002-03-27 03:22:58 EST
I tried also without the proxy, with the same result.
If I registered with the beta servers, how do I remove the certificate, so that I can connect agin?
Comment 6 Adrian Likins 2002-03-27 10:08:03 EST
You will need to rerun rhn_register and register with the live
site, or copy over the original systemsid if you still have it.

Note You need to log in before you can comment on or make changes to this bug.