This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 56141 - Timeout exceeded while attempting fcntl lock! - NFS-mounted mailboxes won't work.
Timeout exceeded while attempting fcntl lock! - NFS-mounted mailboxes won't w...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: balsa (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-13 03:43 EST by Jon Ivar Rykkelid
Modified: 2014-03-16 22:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-14 11:24:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Ivar Rykkelid 2001-11-13 03:43:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-13 i686; Nav)

Description of problem:
Whenever I open a mailbox, I get the message: Timeout exceeded while
attempting fcntl lock!.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start balsa with some nfs-mounted mailboxes
2. Open one of those mailboxes
3.
	

Actual Results:  I get the message "Timeout exceeded while attempting fcntl
lock!"

Expected Results:  I should be able to open mailboxes without this problem,
and I should be able to send mail.

Additional info:

If I try to send a mail I get the message:
"Timeout exceeded while attempting fcntl lock!
Couldn't lock /home/jonry/mail/outbox
Timeout exceeded while attempting fcntl lock!
Couldn't lock /home/jonry/mail/sentbox
Timeout exceeded while attempting fcntl lock!"

Also I get an error message which in English would be something like:
"Problem with SMTP-server: Nothing to do"

Previously I ran balsa from the machine that physically holds my mailboxes
- no problem. From a remote machine, however, it will not work.
Comment 1 Jon Ivar Rykkelid 2001-11-13 04:00:59 EST
(My problem is with the latest balsa 1.2.3, but it may apply to previous
compilations as well.)
Comment 2 Bill Nottingham 2001-11-13 13:02:45 EST
Do you have lockd running on both the server and the client?
Comment 3 Jon Ivar Rykkelid 2001-11-14 10:54:30 EST
Unfortunately not. The server (debian) runs a userspace nfs demon - lockd is run
when/if the server needs it. The client (RedHat) runs lockd... I fear that this
implies that the problem is mine and not yours, but thanks anyway. Btw. I tried
to recompile balsa 1.2.3 - the executable resulted in a segmentation fault.
sigh. :-(
Comment 4 Bill Nottingham 2001-11-14 11:24:39 EST
Unfortunately, for NFS locking to work, lockd must be running on both the client
& server, or the filesystem must be mounted with '-o nolock'.

Note You need to log in before you can comment on or make changes to this bug.