Bug 56159 - pam-0.75-19 leaves turds in /root when I su
pam-0.75-19 leaves turds in /root when I su
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: pam (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-13 09:56 EST by Jonathan Kamens
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-13 15:38:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2001-11-13 09:56:13 EST
Every time I su to root after installing pam-0.75-19, a file with a random
name matching the pattern /root/.xauth* is left on my machine.  This needs
to be cleaned up.
Comment 1 Nalin Dahyabhai 2001-11-13 15:37:59 EST
It should already be cleaned up when you exit the shell (or program) started by
su.  Is this not happening?  If you "su" once, then "su" again on another VT or
in another terminal window, can you see if a temporary file is being generated
when the session is opened, and if it's removed when the session is closed?
If you add "debug" to the end of the pam_xauth line in /etc/pam.d/su, configure
syslog to log "debug" messages, and "su", then exit, does it log removal of the
file?
Comment 2 Jonathan Kamens 2001-11-13 15:44:30 EST
OK, you're right, it does get removed when I exit from the su shell.  I wish
there was a way to do this other than creating a temporary file, though.  If the
su process is killed or crashes or something, it'll be left around as cruft
forever.
Comment 3 Nalin Dahyabhai 2001-11-13 16:06:12 EST
Yes, that is a problem.  The alternative (use .Xauthority and refcounting) was
very complicated, and I think it was the source of the occasional "su segfaults
on logout" bug.  Another alternative (use temp files in /tmp) is no good because
xauth uses lockfiles instead of "real" locking, so it can be screwed up easily,
even by accident.

Note You need to log in before you can comment on or make changes to this bug.