Bug 56184 - undefined automake-symbol in "autoreconf -i"
undefined automake-symbol in "autoreconf -i"
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: autoconf (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-13 12:55 EST by Enrico Scholz
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-27 03:52:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2001-11-13 12:55:55 EST
Description of Problem:

Calling "autoreconf -i" produces the warning

| autoreconf: --add-missing: command not found

under some circumstances. This is caused because of a missing definition of
`automake' somewhere in /usr/bin/autoreconf.

Additionally, `autoreconf' produces lots of warnings regarding obsolete
options.


Version-Release number of selected component (if applicable):

autoconf-2.52-3


How Reproducible:

everytime


Steps to Reproduce:
1. cat <<EOF >configure.ac 
AC_INIT(foo, 0, X)
AM_INIT_AUTOMAKE(foo, 0)

AC_CONFIG_FILES(Makefile)
AC_OUTPUT
EOF

2. touch Makefile.am
3. autoreconf -i

Actual Results:

/usr/bin/autoreconf: --add-missing: command not found
autoconf: warning: -A is obsolete, use --include
autoconf: warning: -l is obsolete, use --include
autoconf: warning: -A is obsolete, use --include
autoconf: warning: -l is obsolete, use --include


Expected Results:

no warnings/errors
Comment 1 Jens Petersen 2001-12-21 00:45:32 EST
Seems this was a bug in 2.52d. I can't reproduce it in 2.52f, which is in
autoconf-2.52-5.

Note You need to log in before you can comment on or make changes to this bug.