Bug 56190 - fails to --rebuild with recent autotools
fails to --rebuild with recent autotools
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: imlib (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-13 14:17 EST by Enrico Scholz
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-13 15:01:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against confgiure.in (2.82 KB, patch)
2001-11-13 14:18 EST, Enrico Scholz
no flags Details | Diff

  None (edit)
Description Enrico Scholz 2001-11-13 14:17:23 EST
Description of Problem:

`rpm --rebuild imlib-1.9.10-2.src.rpm' fails to rebuild with recent
autotools. This seems to be caused by stricter parenthesis-rules of
autoconf-2.52.

acinclude.m4 contains an obsoleted version of libtool.m4 which conflicts
with recent ones. Therefore, it should be deleted.

I will attach a patch against configure.in; in the %build-stage it must be
executed "rm -f acinclude.m4; libtoolize --force; aclocal; autoheader;
automake -a; autoconf" after applying it.


Version-Release number of selected component (if applicable):

imlib-1.9.10-2.src.rpm


Additional Information:
	
autoconf-2.52-3
automake-1.5-1
libtool-1.4.2-2
rpm-4.0.3-1.04
Comment 1 Enrico Scholz 2001-11-13 14:18:07 EST
Created attachment 37442 [details]
Patch against confgiure.in
Comment 2 Havoc Pennington 2002-02-26 16:26:45 EST
Fixed up

Note You need to log in before you can comment on or make changes to this bug.