Bug 56192 - Fails to --rebuild with current autotools
Fails to --rebuild with current autotools
Status: CLOSED DEFERRED
Product: Red Hat Raw Hide
Classification: Retired
Component: eel (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-13 14:38 EST by Enrico Scholz
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-13 15:01:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2001-11-13 14:38:53 EST
Description of Problem:

"rpm --rebuild eel-1.0.2-1.src.rpm" fails with current autotools.
"%define __libtoolize true" somewhere in the .spec-file and omitting
the "automake;autoconf" will be a quick hack; but the build-process
must be fixed in another way...

Problems are caused by providing old and incompatible macros in
aclocal.m4. Usually this can be fixed by calling `aclocal', but
there are some macros (AM_PATH_GNOME, AM_GNOME_GETTEXT) which are
not available (perhaps there should be a BuildReq: on package
providing these).


Version-Release number of selected component (if applicable):

eel-1.0.2-1


How Reproducible:

everytime


Steps to Reproduce:
1. rpm --rebuild eel-1.0.2-1.src.rpm 


Actual Results:

+ automake
automake: configure.in: required file `./depcomp' not found
/usr/share/automake/am/depend2.am: AMDEP does not appear in AM_CONDITIONAL
/usr/share/automake/am/depend2.am: AMDEP does not appear in AM_CONDITIONAL
/usr/share/automake/am/depend2.am: AMDEP does not appear in AM_CONDITIONAL
/usr/share/automake/am/lang-compile.am: AMDEP does not appear in AM_CONDITIONAL
/usr/share/automake/am/depend2.am: AMDEP does not appear in AM_CONDITIONAL
/usr/share/automake/am/depend2.am: AMDEP does not appear in AM_CONDITIONAL
/usr/share/automake/am/depend2.am: AMDEP does not appear in AM_CONDITIONAL
/usr/share/automake/am/lang-compile.am: AMDEP does not appear in AM_CONDITIONAL
Fehler: Bad exit status from /var/tmp/rpm-tmp.27958 (%build)


Additional Information:

autoconf-2.52-3
automake-1.5-1
libtool-1.4.2-2
rpm-4.0.3-1.04
Comment 1 Havoc Pennington 2001-11-13 15:58:25 EST
GNOME is not currently intended to build with the 8.0 build tools,
I'll fix all of it at once at some point, once the overall GNOME direction for
8.0 is clearer.

Note You need to log in before you can comment on or make changes to this bug.