Bug 562000 - [abrt] crash in ibus-1.2.0.20100111-1.fc12
[abrt] crash in ibus-1.2.0.20100111-1.fc12
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
abrt_hash:8af4b44b
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-04 17:40 EST by Andrew Ross
Modified: 2013-10-20 18:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-04 18:05:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (922 bytes, text/plain)
2010-02-04 17:40 EST, Andrew Ross
no flags Details

  None (edit)
Description Andrew Ross 2010-02-04 17:40:42 EST
abrt 1.0.4 detected a crash.

architecture: x86_64
cmdline: python /usr/share/ibus/setup/main.py
component: ibus
executable: /usr/share/ibus/setup/main.py
kernel: 2.6.31.9-174.fc12.x86_64
package: ibus-1.2.0.20100111-1.fc12
release: Fedora release 12 (Constantine)

backtrace
-----
Summary: TB8af4b44b enginedesc.py:105:deserialize:IndexError: pop from empty list

Traceback (most recent call last):
  File "/usr/share/ibus/setup/main.py", line 442, in <module>
    setup = Setup()
  File "/usr/share/ibus/setup/main.py", line 80, in __init__
    self.__init_ui()
  File "/usr/share/ibus/setup/main.py", line 185, in __init_ui
    self.__engines = self.__bus.list_engines()
  File "/usr/lib/python2.6/site-packages/ibus/bus.py", line 130, in list_engines
    return map(serializable.deserialize_object, engines)
  File "/usr/lib/python2.6/site-packages/ibus/serializable.py", line 54, in deserialize_object
    o.deserialize (struct)
  File "/usr/lib/python2.6/site-packages/ibus/enginedesc.py", line 105, in deserialize
    self.__rank = struct.pop(0)
IndexError: pop from empty list

Local variables in innermost frame:
self: <EngineDesc object at 0x2d715f0 (PYIBusEngineDesc at 0x2cda360)>
struct: []
Comment 1 Andrew Ross 2010-02-04 17:40:44 EST
Created attachment 388909 [details]
File: backtrace
Comment 2 Andrew Ross 2010-02-04 17:42:34 EST
ABRT also spat out https://bugzilla.redhat.com/show_bug.cgi?id=522047 at the same time.

Used keyboard shortcut ctrl-space ...
Comment 3 Andrew Ross 2010-02-04 17:45:56 EST
restarted ibus (right click -> restart) and keyboard shortcut worked :-/
Comment 4 Peng Huang 2010-02-04 18:05:26 EST
I think the problem is because you did not restart ibus after upgrade ibus related packages.

Note You need to log in before you can comment on or make changes to this bug.