Bug 562055 - generic fs tests leave secure NFSv4 mount point hang
Summary: generic fs tests leave secure NFSv4 mount point hang
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 592513 698855
TreeView+ depends on / blocked
 
Reported: 2010-02-05 06:21 UTC by Qian Cai
Modified: 2011-05-24 01:37 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 592513 698855 (view as bug list)
Environment:
Last Closed: 2011-05-24 01:37:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sysrq-t output from the client when the test hang (217.59 KB, text/plain)
2010-02-05 06:51 UTC, Qian Cai
no flags Details

Description Qian Cai 2010-02-05 06:21:15 UTC
Description of problem:
When running the test case here,
https://fedoraproject.org/wiki/QA:Testcase_nfs_generic_secure

After running the generic fs tests on the mount point for a while, the client behaved strangely, and commands like df, ps aux would hang,


# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/vg_intels3e314401-lv_root
                      60084332   3182180  53850020   6% /
tmpfs                  4084324         0   4084324   0% /dev/shm
/dev/sda1               198337     58851    129246  32% /boot
<hung...>

Seen the following from the server's /var/log/messages,
Feb  5 00:00:52 amd-toonie2-01 kernel: RPC: AUTH_GSS upcall timed out.
Feb  5 00:00:52 amd-toonie2-01 kernel: Please check user daemon is running.
Feb  5 00:00:55 amd-toonie2-01 rpc.gssd[1342]: WARNING: can't create tcp rpc_clnt to server intel-s3e3144-01.rhts.eng.nay.redhat.com for user with uid 0: RPC: Remote system error - No route to host
Feb  5 00:00:56 amd-toonie2-01 rpc.gssd[1342]: WARNING: can't create tcp rpc_clnt to server intel-s3e3144-01.rhts.eng.nay.redhat.com for user with uid 0: RPC: Remote system error - No route to host
Feb  5 00:23:00 amd-toonie2-01 kernel: iint_free: readcount: 1
Feb  5 00:23:00 amd-toonie2-01 kernel: iint_free: writecount: -1

Version-Release number of selected component (if applicable):
nfs-utils-1.2.1-15.fc13
kernel-2.6.33-0.16.rc4.git6.fc13

How reproducible:
always

Steps to Reproduce:
https://fedoraproject.org/wiki/QA:Testcase_nfs_generic_secure
  
Actual results:
Tests were unable to complete due to mount point hang.

Expected results:
Tests can complete.

Comment 1 Qian Cai 2010-02-05 06:51:08 UTC
Created attachment 388995 [details]
sysrq-t output from the client when the test hang

Comment 2 Miroslav Vadkerti 2010-02-05 13:31:55 UTC
The same beaviour in my tests

Comment 3 Bug Zapper 2010-03-15 14:24:00 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Qian Cai 2011-04-18 09:03:02 UTC
Any update?

Comment 5 Jiajian Yang 2011-05-23 07:06:44 UTC
I tried to reproduce the bug on Fedora 14, 

Kernel 2.6.35.13-91.fc14.x86_64
nfs-utils 1.2.3-6.fc14.x86_64

This bug cannot be reproduced in my environment, i.e. everything goes fine after the fs test. And all the test can be completed.

Comment 6 Jiajian Yang 2011-05-23 07:27:13 UTC
I tried to reproduce the bug on Fedora 14, 

Kernel 2.6.35.13-91.fc14.x86_64
nfs-utils 1.2.3-6.fc14.x86_64

This bug cannot be reproduced in my environment, i.e. everything goes fine after the fs test. And all the test can be completed.


Note You need to log in before you can comment on or make changes to this bug.