Bug 56219 - kernel-2.4.9-12.i686.rpm failed dependencies
kernel-2.4.9-12.i686.rpm failed dependencies
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-13 18:53 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-13 18:53:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-13 18:53:09 EST
Description of Problem:
installing kernel-2.4.9-12.i686.rpm (a security patch) on RH 7.1 prompts
for the install of  mkinitrd-3.2.6-1.i386.rpm. Attempting an install of 
mkinitrd-3.2.6-1.i386.rpm produces the following dependency:
	'filesystem >= 2.1.0 is needed by mkinitrd-3.2.6-1'

Unfortunately, there seems to be no such rpm package available for RH 7.1,
therefore the entire dependency chain of this security upgrade fails.


Version-Release number of selected component (if applicable):
7.1

How Reproducible:


Steps to Reproduce:
1. rpm -Uvh kernel-headers-2.4.9-12.i386.rpm kernel-source-2.4.9-12.i386.rpm

2. rpm -ivh kernel-2.4.9-12.i686.rpm (depends on install of
mkinitrd-3.2.6-1.i386.rpm)

3. rpm -ivh mkinitrd-3.2.6-1.i386.rpm (filesystem >= 2.1.0 is needed by
mkinitrd-3.2.6-1)

4. no filesystem-2.1.0.i386.rpm is available for download via ftp for Red
Hat Linux 7.1

Actual Results:
same

Expected Results:
no failed dependencies or existing packages to satisfy dependencies.

Additional Information:
Comment 1 Bill Nottingham 2001-11-13 23:23:12 EST
Look in the noarch directory.

Note You need to log in before you can comment on or make changes to this bug.