Bug 56221 - Bad hostname when dual booting win98 on intel 850GB mlb
Summary: Bad hostname when dual booting win98 on intel 850GB mlb
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dhcpcd (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-14 00:37 UTC by mc1
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 17:18:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mc1 2001-11-14 00:37:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Just FYI: When dual booting (have only used Win98) on an intel 850GB MLB
using onboard NIC, configured for dhcp, and activated on startup
Linux automatically uses the Win98 "computername" as its host name. This
causes gnome to go haywire and freeze. If the windows computer name is
changed and the system is then booted to linux the hostname also changes to
match. The problem seems to stem from the onboard NIC holding on to the
windows hostname (this would imply a memory area that fakes a dhcp reply to
speed windows boot times). When i changed to a standard PCI NIC and
reinstalled Red Hat the problem was gone.
Ps. It took me 10 or 12 reloads before it occoured to me.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Configure a system using the intel 850GB motherboard w/ onboard pro100b
NIC, and 2 fixed disks.
2. load windows of hdd1
3.Setup windows for dhcp (broadband, dsl....)
4 load linux on hdd2 set eth0 for dhcp. 
5. start lunux and check the hostname at a bash prompt, it will match the
windows computername.
	

Additional info:

Comment 1 Elliot Lee 2002-01-04 20:28:06 UTC
ENOCLUE - don't have the hardware available, so can't reproduce the problem.

If you find a solution for using the onboard NIC, please let us know.


Note You need to log in before you can comment on or make changes to this bug.