Bug 5623 - setup is missing a csh.cshrc configuration file
setup is missing a csh.cshrc configuration file
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: setup (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-06 05:21 EDT by marc.lefranc
Modified: 2014-03-16 22:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-06 11:34:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description marc.lefranc 1999-10-06 05:21:53 EDT
In the setup package, the csh.cshrc has been replaced by a
csh.login configuration file. However, the latter is only
read for a login shell, not by a shell started in an xterm,
for example. Since a login shell also reads csh.cshrc, the
basic configuration should be in csh.cshrc, and only
login-specific stuff should go in csh.login.

Reference : tcsh(1) man page

This is pretty obvious to anyone familiar with unix shells.
Comment 1 Bill Nottingham 1999-10-06 11:34:59 EDT
See bug #2931 for rationale on why this was changed.

Note You need to log in before you can comment on or make changes to this bug.