Bug 56231 - Balsa segfaults when using the RPM built from the SRPM
Balsa segfaults when using the RPM built from the SRPM
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: balsa (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-14 07:01 EST by svendsen
Modified: 2014-03-16 22:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-14 12:47:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description svendsen 2001-11-14 07:01:55 EST
Description of Problem:
The binary segfaults when calling
 setlocale(LC_CTYPE, gnome_i18n_get_language());
in src/main.c, just below int main().

Version-Release number of selected component (if applicable):
balsa-1.2.3-1.src.rpm

How Reproducible:


Steps to Reproduce:
1. Get the balsa-1.2.3-1.src.rpm
2. rpm -i balsa-1.2.3-1.src.rpm
3. rpm -bb balsa.spec in usr/src.../BUILD/
4. Upgrade to the new RPM
5. Type balsa	

Actual Results:
Segmentation fault

Expected Results:
Balsa would come up

Additional Information:
Environment:
PWD=/usr/src/redhat/BUILD
XAUTHORITY=/root/.xauthlQFnNW
PAGER=less
HOSTNAME=ludvig.seabed.no
QTDIR=/usr/lib/qt-2.3.1
CLASSPATH=:/home/svendsen/classes/comm.jar:/home/svendsen/classes/jcl.jar
LESSOPEN=|/usr/bin/lesspipe.sh %s
MANPATH=:/usr/local/man:/home/advance/ProMAX/port/man:/home/advance/ProMAX/port/man/man
PS1=[\u@\h \w]$ 
MOZILLA_FIVE_HOME=/usr/local/mozilla
ENLIGHTENMENT_ROOT=/usr/share/enlightenment
KDEDIR=/usr
ESPEAKER=gudleik:5001
USER=svendsen
LS_COLORS=no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=01;32:*.cmd=01;32:*.exe=01;32:*.com=01;32:*.btm=01;32:*.bat=01;32:*.sh=01;32:*.csh=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tz=01;31:*.rpm=01;31:*.cpio=01;31:*.jpg=01;35:*.gif=01;35:*.bmp=01;35:*.xbm=01;35:*.xpm=01;35:*.png=01;35:*.tif=01;35:MACHTYPE=i386-redhat-linux-gnu
OPERA_PLUGIN_PATH=/usr/java/jre1.3.1/plugin/i386/ns4
LC_ALL=no_NO
MAIL=/var/spool/mail/svendsen
OLDPWD=/usr/src/redhat/SPECS
LANG=no
SBCL_HOME=/home/svendsen/sbcl-0.6.12/output
DISPLAY=ludvig.seabed.no:10.0
CWPROOT=/home/svendsen/CWP
LOGNAME=svendsen
SHLVL=2
SHELL=/bin/bash
PRINTER=gudleik
HOSTTYPE=i386
OSTYPE=linux-gnu
HISTSIZE=100000
HOME=/root
TERM=vt100
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
ROOTSYS=/usr/local/root-3.02.02/
PATH=/usr/local/root-3.02.02//bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/sbin:/sbin:/port/bin:/sys/bin:/sys/exe:/sys/exe/frame/bin:/usr/ccs/bin:/home/svendsen/CWP/bin:/advance/port/bin:/usr/openwin/bin:/usr/ucb:/usr/local/bin
LESSCHARSET=latin1
SSH_TTY=/dev/pts/4
_=/usr/bin/printenv
Comment 1 Bill Nottingham 2001-11-14 11:25:18 EST
Ugh.

What gnome-libs do you have installed?
Comment 2 svendsen 2001-11-14 11:37:01 EST
gnome-libs-1.2.13-16
gnome-libs-devel-1.2.13-16
Comment 3 Bill Nottingham 2001-11-14 11:42:44 EST
This is stock 7.2 + updates, yes?

What language are you running in?
Comment 4 svendsen 2001-11-14 11:51:00 EST
Yes, 7.2 plus upgrades.  
Language is LANG=no, LC_ALL=no_NO, norwegian that is.
It does not help to do this:
 $ export LC_ALL=C
 $ export LANG=C

When setting locale to C, it seems to crash at a different point:
This what gdb tells me:

(gdb) back
#0  0x0 in ?? ()
#1  0x4010f3d3 in _IO_vfprintf (fp=0xbffff4b0, fmt0=0x402581ec "%d", 
    ap=0xbffff5e0) at iovfprintf.c:604
#2  0x401a2be4 in _IO_vsnprintf (string=0xbffff5e0 "", maxlen=12, 
    format=0x402581ec "%d", args=0xbffff5dc) at vsnprintf.c:130
#3  0x40189e4b in __snprintf (s=0xbffff5e0 "", maxlen=12, 
    format=0x402581ec "%d") at snprintf.c:37
#4  0x4023fdfd in __nscd_getpwuid_r (uid=1001, resultbuf=0xbffff670, 
    buffer=0x814b098 "", buflen=1024) at nscd_getpw_r.c:58
#5  0x401e44ac in __getpwuid_r (uid=1001, resbuf=0xbffff670, 
    buffer=0x814b098 "", buflen=1024, result=0xbffff66c)
    at ../nss/getXXbyYY_r.c:156
#6  0x4092b362 in g_get_any_init ()
#7  0x4092b6bc in g_get_home_dir ()
#8  0x407341ab in gnomelib_init ()
#9  0x4066ba00 in gnome_init_with_popt_table ()
#10 0x8090b67 in balsa_init (argc=1, argv=0xbffff7f4) at main.c:130
#11 0x8090eec in main (argc=1, argv=0xbffff7f4) at main.c:294
#12 0x40146627 in __libc_start_main (main=0x8090e98 <main>, argc=1, 
    ubp_av=0xbffff7f4, init=0x8061fac <_init>, fini=0x8111590 <_fini>, 
    rtld_fini=0x4000dcd4 <_dl_fini>, stack_end=0xbffff7ec)
    at ../sysdeps/generic/libc-start.c:129
Comment 5 Bill Nottingham 2001-11-14 11:53:53 EST
What are you using for NSS - ldap, NIS, local passwords, etc?

Do you notice *any* difference at all in the binary requirements (via ldd)
between the rebuilt version and the shipped version?
Comment 6 svendsen 2001-11-14 12:31:24 EST
There is no difference in the ldd output between the two versions.
Passwords and stuff goes trough NIS, no local passwords.

However, I have discovered that there is two points of failure here.
When language is set to norwegian, balsa segfaults when calling
setlocale in the beginning.  When LC_ALL and LANG are set to C the 
segfault happens somewhere inside gnome_init_with_popt_table, in the
nss stuff.

libc is libc-5.3.12-31
Comment 7 svendsen 2001-11-14 12:38:25 EST
Perhaps I should add that the *only* differences in ldd are at the 
adresses of the symbols:

	libgnomeui.so.32 => /usr/lib/libgnomeui.so.32 (0x405f9000)
	libgnomeui.so.32 => /usr/lib/libgnomeui.so.32 (0x40601000)
                                                       ^^^^^^^^^^
Which I regard as a normal thing.
Comment 8 svendsen 2001-11-14 12:40:43 EST
Ouch, _g_libc is:

glibc-common-2.2.4-19
glibc-profile-2.2.4-19
glibc-2.2.4-19
Comment 9 Bill Nottingham 2001-11-14 12:44:26 EST
Hm, I can't reproduce it here at all.
Comment 10 Bill Nottingham 2001-11-14 12:47:10 EST
Dumb question: were you running in Norwegian locale when you rebuilt it?

(Not that this really *should* make a lot of difference, but...)
Comment 11 Bill Nottingham 2002-01-25 00:56:41 EST
I tried on a variety of systems, and I could never reproduce this.

Note You need to log in before you can comment on or make changes to this bug.