Bug 56233 - X crashes went clock changes a huge ammount
Summary: X crashes went clock changes a huge ammount
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-14 13:27 UTC by Nathan G. Grennan
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-17 07:22:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nathan G. Grennan 2001-11-14 13:27:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5+)
Gecko/20011018 Netscape6/6.5

Description of problem:
I had upgraded by bios and cleared it with the jumper. I forgot to reset
the clock and ntp didn't reset it because the difference was over 1000
seconds. When untaring a file I got alot of error message about future
dates and figured out I had forgot to set the time. So I used ntpupdate
servername  and updated it. I have done small changes before to test ntpd,
say by changing the clock by 10 minutes. When I currented the time it would
start the screen saver, naturally. This time it crashed all of X and I got
dropped back at the gdm login prompt.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set clock way back, ie. Jan 1 1970 1am
2. Start X
3. Set time to current time

	

Actual Results:  X crashs

Expected Results:  Programs to update, maybe the screensaver to come on if
it is running, but not for X to crash

Additional info:

Comment 1 Mike A. Harris 2002-03-14 19:32:13 UTC
This bug was just fixed I believe, and is in the current Rawhide
version of X 4.2.0-6.45, and also in 4.1.0-23 which is soon to be
released as erratum.  It was fixed by Chris Blizzard and Keith
Packard, and was due to a time wraparound bug in xdmcp.c


Note You need to log in before you can comment on or make changes to this bug.