Bug 562858 - Can't locate XML/Writer.pm - missing dependency
Can't locate XML/Writer.pm - missing dependency
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
: 563506 568775 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-08 10:32 EST by Dan Horák
Modified: 2010-03-01 20:02 EST (History)
4 users (show)

See Also:
Fixed In Version: libguestfs-1.0.81-1.fc12.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-01 20:02:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2010-02-08 10:32:50 EST
Running "guestfish -i rawhide" on my VM called "rawhide" throws an error:

Can't locate XML/Writer.pm in @INC (@INC contains: /usr/local/lib64/perl5/site_perl/5.10.0/x86_64-linux-thread-multi /usr/local/lib/perl5/site_perl/5.10.0 /usr/lib64/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/5.10.0 /usr/lib/perl5/site_perl .) at /usr/bin/virt-inspector line 29.
BEGIN failed--compilation aborted at /usr/bin/virt-inspector line 29.


Version-Release number of selected component (if applicable):
libguestfs-tools-1.0.81-1.fc12.4.x86_64

Reason: perl-XML-Writer dependency is missing for libguestfs-tools (specifically virt-inspector)
Comment 1 Richard W.M. Jones 2010-02-08 11:27:06 EST
Hmm yes, missing dep.

Thanks for reporting this.  I will add this shortly, although at the
moment we cannot build libguestfs in Rawhide for unrelated reasons.
Comment 2 Richard W.M. Jones 2010-02-08 12:02:07 EST
Build for F-12:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1969251
Comment 3 Fedora Update System 2010-02-08 18:47:47 EST
libguestfs-1.0.81-1.fc12.6 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/libguestfs-1.0.81-1.fc12.6
Comment 4 Fedora Update System 2010-02-09 16:00:36 EST
libguestfs-1.0.81-1.fc12.6 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libguestfs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1682
Comment 5 Richard W.M. Jones 2010-02-10 08:50:45 EST
*** Bug 563506 has been marked as a duplicate of this bug. ***
Comment 6 Richard W.M. Jones 2010-02-26 11:13:43 EST
*** Bug 568775 has been marked as a duplicate of this bug. ***
Comment 7 Richard W.M. Jones 2010-02-26 11:16:36 EST
I submitted this package for stable.
Comment 8 Fedora Update System 2010-03-01 20:02:06 EST
libguestfs-1.0.81-1.fc12.6 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.