Bug 56301 - Separate languages and sort order would be very useful
Separate languages and sort order would be very useful
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-language (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
: FutureFeature
: 57968 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-15 05:52 EST by Telsa Gwynne
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-09 14:04:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Telsa Gwynne 2001-11-15 05:52:02 EST
I love being able to have British spelling, but I find that I am
terribly used to the C locale's sort order. It would be extremely
nice to have a separate page for LC_COLLATE settings.

Something like a second page which explains "You have chosen foo for
your language. This also affects the way results of commands involving
'sort' 'tr' and other utilities will be displayed. Some people prefer
to have these results sorted case-sensitively, with any capital letters
coming before any lower-case letters. How do you prefer this sorting
order?

    [  ] AaBbCc...XxYyZz       [   ] ABC..XYZabc...xyz
         LC_COLLATE="foo"            LC_COLLATE="C"

Of course, once this is in, someone will want LC_MONETARY, and someone
else something else, but I think LC_COLLATE no longer being C is 
throwing people. See bug #17204 for an example.
Comment 1 Owen Taylor 2002-01-24 16:55:28 EST
*** Bug 57968 has been marked as a duplicate of this bug. ***
Comment 2 Owen Taylor 2002-01-24 19:00:05 EST
*** Bug 57968 has been marked as a duplicate of this bug. ***
Comment 3 Owen Taylor 2002-08-09 14:04:13 EDT
Reassigning to redhat-config-language. (I have a slightly hard
time imagining how such an option could be presented to the UI
in a friendly way for new users.)
Comment 4 Brent Fox 2002-08-11 09:32:44 EDT
I'm with Owen.  I don't really want to start down the path of making rather
obscure options presented in the UI.  redhat-config-language has a really simple
UI and I want it to stay that way, especially since I want anaconda to pull it's
UI in for the next release, they way that it currently does for
redhat-config-keyboard.

Note You need to log in before you can comment on or make changes to this bug.