Bug 56330 - new aic7xxx driver fails on old hardware [Uncaught Anaconda traceback with AIC-7xxx and SCSI CD upgrade]
new aic7xxx driver fails on old hardware [Uncaught Anaconda traceback with AI...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-15 13:02 EST by R P Herrold
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-23 14:11:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda traceback of uncaught exception (66.55 KB, text/plain)
2001-11-15 13:05 EST, R P Herrold
no flags Details
dmesg-scsi-HD-freeze.txt - last line -- is this showing SCSI command overflow? (6.51 KB, text/plain)
2002-04-16 10:45 EDT, R P Herrold
no flags Details
SCSI errors trying to burn CD - dmesg, lspci and more (13.96 KB, text/plain)
2002-04-16 16:22 EDT, R P Herrold
no flags Details

  None (edit)
Description R P Herrold 2001-11-15 13:02:43 EST
Uncaught Anaconda traceback with AIC-7xxx and SCSI CD upgrade

RH 7.2 gold CD's

Adaptec PCI controller, relatively recent SCSI Read/burner

Will attach traceback in a moment
Comment 1 R P Herrold 2001-11-15 13:05:18 EST
Created attachment 37604 [details]
anaconda traceback of uncaught exception
Comment 2 R P Herrold 2001-11-15 13:06:20 EST
If you need further details (lspci, bios versions, etc), please remind me that
this was from my old ws6
Comment 3 Brent Fox 2001-11-20 13:36:01 EST
Are you sure the cd is good?  Anaconda is just trying to import a Python module
that it needs, but it can't find it.
Comment 4 R P Herrold 2001-11-20 15:26:06 EST
After filing this, I used the same physical CD set for three other installs ... part of my install procedure is run my audit files, which run a    rpm -Va  
and no errors exist in those systems ...  dunno.  The reason I mentioned the AIC-7xxx/SCSI CD combo  is that the retry logic on that SCSI driver was 
a bit of an issue late in the RH 7.2 Beta cycle
Comment 5 Michael Fulbright 2002-01-15 16:50:12 EST
There are lots of sense errors in the log - is it possible the CD drive in this
system is having problems with the install media?
Comment 6 R P Herrold 2002-01-16 09:08:24 EST
Possible but quite unlikey -- it is a recently bought new Mashshusita  <sp?> 
SCSI CD - RW ...Irrespective of the drive issue, should not all return codes 
be tested and directed to a handler ('caught', as the saying goes)?
Comment 7 Michael Fulbright 2002-01-16 14:44:30 EST
Perhaps, although if read errors keep python 'import' statements from working
you're already in bad shape.  I have not seen this particular failure mode
before, but based on other similar exceptions it is almost always due to a
problem reading a CD.

Can you try a NFS install from another machine, for example?
Comment 8 Jeremy Katz 2002-03-26 19:59:49 EST
Any information on if this machine can install via other methods?
Comment 9 R P Herrold 2002-04-16 10:44:14 EDT
Sorry about delay -- have been briefly unavailable.
------------------

there are ZARRO media errors or retries during my testing sesions -- 

It looks as though the AIC-7xxx SCSI driver has too many pending requests to the
CD, and it is locking up there. -- Attachment in a moment.
Comment 10 R P Herrold 2002-04-16 10:45:01 EDT
Created attachment 54045 [details]
dmesg-scsi-HD-freeze.txt - last line -- is this showing SCSI command overflow?
Comment 11 Matt Wilson 2002-04-16 15:56:36 EDT
ugh, this is an original Pentium?

These are the SCSI errors we're talking about:

<4>scsi0: ERROR on channel 0, id 5, lun 0, CDB: 0x28 00 00 04 5a 85 00 00 06 00 
<4>Info fld=0x45a85, Current sd0b:00: sns = f0  3
<4>ASC= 2 ASCQ= 0
<4>Raw sense data:0xf0 0x00 0x03 0x00 0x04 0x5a 0x85 0x0a 0x00 0x00 0x00 0x00
0x02 0x00 0x00 0x00 0x00 0x00 
<4> I/O error: dev 0b:00, sector 1141268
<4>scsi0: ERROR on channel 0, id 5, lun 0, CDB: 0x28 00 00 04 5a 86 00 00 05 00 
<4>Info fld=0x45a86, Current sd0b:00: sns = f0  3
<4>ASC= 2 ASCQ= 0
<4>Raw sense data:0xf0 0x00 0x03 0x00 0x04 0x5a 0x86 0x0a 0x00 0x00 0x00 0x00
0x02 0x00 0x00 0x00 0x00 0x00 
<4> I/O error: dev 0b:00, sector 1141272
<4>Error -3 while decompressing!
<4>c0441860(-1944672)->c688d000(4096)
<4>Error -3 while decompressing!
<4>c04410f4(-1942762)->c7e53000(4096)
<4>Error -3 while decompressing!
<4>c0266c0a(-10)->c7e5b000(4096)
Comment 12 R P Herrold 2002-04-16 16:21:31 EDT
Unit is a dual processor, matched lot (consequetive serial numbers) P-150, on a
Tyan D-1563 -- the D indicates dual processors

I have new SCSI errors trying to burn a CD -- will attach in a moment

This is a long time testing unit which shows aic-7xxx SCSI driver errors well,
it seems
Comment 13 R P Herrold 2002-04-16 16:22:24 EDT
Created attachment 54085 [details]
SCSI errors trying to burn CD - dmesg, lspci and more
Comment 14 R P Herrold 2002-04-16 16:23:35 EDT
My unit:  oldpokey

updates for lilo.conf produced a file which will not boot for either SMP or UP

I will try to hook up a serial cable to trach the errors and file separately.
Comment 15 R P Herrold 2002-04-16 16:26:11 EDT
device 0:0:0 is the hard drive, on the internal UW channel; CD drive 0:5:0 is on
the SCSI-II channel, with active termination after it on the chain, and the CD
drive strapped for external termination.
Comment 16 Doug Ledford 2002-04-23 14:11:33 EDT
These are the SCSI errors we're talking about:

<4>scsi0: ERROR on channel 0, id 5, lun 0, CDB: 0x28 00 00 04 5a 85 00 00 06 00 
<4>Info fld=0x45a85, Current sd0b:00: sns = f0  3
<4>ASC= 2 ASCQ= 0
<4>Raw sense data:0xf0 0x00 0x03 0x00 0x04 0x5a 0x85 0x0a 0x00 0x00 0x00 0x00
0x02 0x00 0x00 0x00 0x00 0x00 
<4> I/O error: dev 0b:00, sector 1141268

These aren't driver problems.  These are the CD drive telling the machine that
it can't read the CD.  That simple, media issue (the media may be fine on other
machines, but for some reason this particular drive can't read this media). 
I'll look at the errors during burning next....
Comment 17 Doug Ledford 2002-04-23 14:17:04 EDT
The cd writing errors are also valid device errors.  In general, any time you
have an error that reports a CHECK_CONDITION or REQUEST_SENSE return value, it
means that the driver and the device are sucessfully talking (which is the limit
of the driver's responsibility BTW), but that the device is having problems of
it's own for whatever reason.  In the case of the burning, I saw two device
reported errors of concern.  One was a complaint that it could write track 0 of
the media, so a burning error.  The second was a complaint that it didn't like
the raw SCSI command that cdrecord sent to it (the invalid command sense code).
 Both of those indicate that the driver is working fine and that the problem
lies elsewhere (either in media or an imcompatibility between the particular
internal raw SCSI command driver in cdrecord and the Matshita device firmware).
 Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.