Bug 563457 - [abrt] crash in yum-utils-1.1.25-1.fc12
[abrt] crash in yum-utils-1.1.25-1.fc12
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
abrt_hash:eb4c4c95
:
: 563368 563946 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-10 05:17 EST by Till Maas
Modified: 2014-01-21 18:13 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-12 10:48:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.21 KB, text/plain)
2010-02-10 05:17 EST, Till Maas
no flags Details

  None (edit)
Description Till Maas 2010-02-10 05:17:06 EST
abrt 1.0.6 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python -tt /usr/bin/yum-builddep gtranslator-1.9.7-1.fc13.src.rpm
component: yum-utils
executable: /usr/bin/yum-builddep
kernel: 2.6.31.12-174.2.3.fc12.x86_64
package: yum-utils-1.1.25-1.fc12
release: Fedora release 12 (Constantine)

backtrace
-----
Summary: TBeb4c4c95 yum-builddep:173:get_build_deps:UnboundLocalError: local variable 'toActOn' referenced before assignment

Traceback (most recent call last):
  File "/usr/bin/yum-builddep", line 196, in <module>
    util = YumBuildDep()
  File "/usr/bin/yum-builddep", line 64, in __init__
    self.main()
  File "/usr/bin/yum-builddep", line 93, in main
    self.get_build_deps(opts)
  File "/usr/bin/yum-builddep", line 173, in get_build_deps
    for srpm in toActOn:
UnboundLocalError: local variable 'toActOn' referenced before assignment

Local variables in innermost frame:
self: <__main__.YumBuildDep object at 0x12f5350>
srpms: [<YumLocalPackage : gtranslator-1.9.7-1.fc13.src (0x154b910)>]
opts: <Values at 0x1522560: {'skipbroken': None, 'verbose': None, 'errorlevel': None, 'color': None, 'repos': [], 'conffile': '/etc/yum/yum.conf', 'exclude': [], 'enableplugins': [], 'nogpgcheck': None, 'disableplugins': [], 'sleeptime': None, 'version': None, 'obsoletes': None, 'debuglevel': None, 'cacheonly': None, 'showdupesfromrepos': None, 'assumeyes': None, 'disablepresto': False, 'installroot': None, 'quiet': None, 'tolerant': None, 'disableexcludes': [], 'noplugins': None}>
srcnames: []
arg: 'gtranslator-1.9.7-1.fc13.src.rpm'

How to reproduce
-----
1.  yum-builddep gtranslator-1.9.7-1.fc13.src.rpm
Comment 1 Till Maas 2010-02-10 05:17:09 EST
Created attachment 389961 [details]
File: backtrace
Comment 2 Till Maas 2010-02-10 05:18:20 EST
*** Bug 563368 has been marked as a duplicate of this bug. ***
Comment 3 Tim Lauridsen 2010-02-12 10:48:17 EST
Fixed in yum-utils-1.1.26

https://admin.fedoraproject.org/updates/F12/FEDORA-2010-1728
Comment 4 Tim Lauridsen 2010-02-12 10:57:53 EST
*** Bug 563946 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.