Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 56353 - zsh doesn't work over serial port.
zsh doesn't work over serial port.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: zsh (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-15 20:02 EST by hjl
Modified: 2017-05-17 07:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-17 07:53:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch (2.07 KB, patch)
2001-11-15 20:02 EST, hjl
no flags Details | Diff
A patch to support serial port. (1.76 KB, patch)
2002-05-20 19:00 EDT, hjl
no flags Details | Diff

  None (edit)
Description hjl 2001-11-15 20:02:17 EST
I can't log in from a serial port under kernel 2.4.9-12. It used
to work fine. zsh blocks at

open("/dev/ttyS0", O_RDWR|O_NOCTTY)
Comment 1 hjl 2001-11-15 20:02:46 EST
Created attachment 37703 [details]
A patch
Comment 2 Trond Eivind Glomsrxd 2001-11-16 11:26:43 EST
Can you see if using zsh as shipped with Red Hat Linux 7.2 helps?
Comment 3 hjl 2001-11-16 11:31:19 EST
I did try zsh from RedHat 7.2. It has the same problem.
Comment 4 Trond Eivind Glomsrxd 2001-11-16 14:31:10 EST
The one from rawhide? (4.0.4)
Comment 5 hjl 2001-11-16 14:46:10 EST
The same.

# rpm -q zsh
zsh-4.0.4-1
# strace -p 20994
open("/dev/ttyS0", O_RDWR|O_NOCTTY|O_LARGEFILE
Comment 6 hjl 2002-05-20 18:59:16 EDT
zsh in RedHat 7.3 has the same problem. I am uploading a patch.
Comment 7 hjl 2002-05-20 19:00:12 EDT
Created attachment 58047 [details]
A patch to support serial port.
Comment 8 Trond Eivind Glomsrxd 2002-06-28 13:15:27 EDT
Patch added to zsh-4.0.4-8
Comment 9 Kamil Dudka 2016-12-14 09:55:33 EST
Has this patch been ever proposed to Zsh upstream?
Comment 10 Kamil Dudka 2017-05-17 07:42:14 EDT
According to the following thread at the upstream mailing list:

https://www.zsh.org/mla/users/2009/msg00287.html

... it was not a bug of Zsh, so the fix does not belong there.  A possible workaround is to use 'agetty -L':

https://www.zsh.org/mla/users/2009/msg00289.html

... or mgetty:

http://www.zsh.org/mla/workers/2001/msg00862.html
Comment 11 Kamil Dudka 2017-05-17 07:53:12 EDT
patch removed in zsh-5.3.1-6.fc27 by the following downstream commit:

https://src.fedoraproject.org/cgit/rpms/zsh.git/commit/?id=16616a0f

Note You need to log in before you can comment on or make changes to this bug.