Bug 56358 - KPackage chokes on + node expansion under the updated tab
KPackage chokes on + node expansion under the updated tab
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kpackage (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-15 22:58 EST by Eric Klingelberger
Modified: 2007-04-18 12:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-19 23:55:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Klingelberger 2001-11-15 22:58:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686; Nav)

Description of problem:
100% recreatable

Steps to recreate:
1. open kpackage
2. click on the updated tab
3. click on the RPM  - node
4. click on the RPM  + node
5. wala there you have it.


(no debugging symbols found)...(no debugging symbols found)...
0x40f4b669 in __wait4 () from /lib/i686/libc.so.6
#0  0x40f4b669 in __wait4 () from /lib/i686/libc.so.6
#1  0x40fc7154 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x405b0838 in KCrash::defaultCrashHandler () at eval.c:41
#3  <signal handler called>
#4  0x408f7605 in QListViewItem::itemBelow ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#5  0x408fc61a in QListView::setOpen () from
/usr/lib/qt-2.3.1/lib/libqt.so.2
#6  0x408f79ae in QListView::contentsMousePressEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#7  0x40368cd6 in KListView::contentsMousePressEvent () at eval.c:41
#8  0x08084c6a in procbuf::~procbuf () at eval.c:41
#9  0x40938c31 in QScrollView::viewportMousePressEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#10 0x40938461 in QScrollView::eventFilter ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#11 0x408f74d4 in QListView::eventFilter ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#12 0x4085bcab in QObject::activate_filters ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#13 0x408a4dbe in QWidget::event () from /usr/lib/qt-2.3.1/lib/libqt.so.2

#14 0x4080d891 in QApplication::notify () from
/usr/lib/qt-2.3.1/lib/libqt.so.2

#15 0x40517c89 in KApplication::notify () at eval.c:41
#16 0x407dbd5f in QETWidget::translateMouseEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#17 0x407d9248 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#18 0x407d821a in QApplication::processNextEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#19 0x4080f74c in QApplication::enter_loop ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#20 0x407d8197 in QApplication::exec () from
/usr/lib/qt-2.3.1/lib/libqt.so.2
#21 0x08075b5d in KDialog::marginHint () at eval.c:41
#22 0x40ead507 in __libc_start_main (
    main=0x80756d0 <KDialog::marginHint(void)+109352>, argc=7, 
    ubp_av=0xbffffb54, init=0x8057140 <_init>, fini=0x80a7b30 <_fini>, 
    rtld_fini=0x4000dc14 <_dl_fini>, stack_end=0xbffffb4c)
    at ../sysdeps/generic/libc-start.c:129

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. open kpackage
2. click on the updated tab
3. click on the RPM  - node
4. click on the RPM  + node
5. wala there you have it.	

Actual Results:  signal 11 (SIGSEGV)
crashes the whole application

Expected Results:  should not crash the application

Additional info:
Comment 1 Bill Nottingham 2003-02-19 23:55:40 EST
At this point, since we don't ship kpackage currently, we most likely will not
address these bugs.

Note You need to log in before you can comment on or make changes to this bug.