Bug 56360 - Internal compiler error in copy_to_mode_reg, at explow.c:789
Summary: Internal compiler error in copy_to_mode_reg, at explow.c:789
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.1
Hardware: alpha Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL: http://ftp.mplayerhq.hu/MPlayer/relea...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-16 04:20 UTC by Charles R. Anderson
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 18:11:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Processed source from MPlayer-0.50/encore/mot_est_mb.c (89.33 KB, text/plain)
2002-03-28 01:03 UTC, Charles R. Anderson
no flags Details

Description Charles R. Anderson 2001-11-16 04:20:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux sparc64; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
When trying to compile encore/mot_est_mb.c from MPlayer-0.50, the compiler
aborts with an "Internal compiler error in copy_to_mode_reg, at explow.c:789".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Get MPlayer-0.50 from
http://ftp.mplayerhq.hu/MPlayer/releases/MPlayer-0.50.tar.bz2
2. Unpack and cd to the MPlayer-0.50/encore subdirectory.
3. gcc -c -O4 -mcpu=ev56 -pipe -ffast-math -fomit-frame-pointer -I.
-I/usr/local/include  -o mot_est_mb.o mot_est_mb.c



Actual Results:  gcc -c -O4  -mcpu=ev56 -pipe -ffast-math
-fomit-frame-pointer -I. -I/usr/local/include  -o mot_est_mb.o mot_est_mb.c
mot_est_mb.c: In function `MBMotionEstimation':
mot_est_mb.c:619: Internal compiler error in copy_to_mode_reg, at explow.c:789
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.



Expected Results:  mot_est_mb.o should be created correctly.

Additional info:

I tried various optimizations, including -O0 and leaving off -mcpu=ev56,
with no change.  The file compiles properly with kgcc
(compat-egcs-6.2-1.1.2.14) and on other architectures (RH 7.2 i386, RH 7.1
i386, RH 7.0 i386, RH 6.2 i386, RH 6.2 sparc.) with their standard gcc's.  

The compiler that fails is:

>rpm -q gcc
gcc-2.96-87
>gcc -v
Reading specs from /usr/lib/gcc-lib/alpha-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-87)

Comment 1 Jakub Jelinek 2001-11-28 10:19:32 UTC
Please try gcc-c++-2.96-100 or above.
If the bug still remains, post the exact gcc command line here and attach
preprocessed source (use -save-temps and gcc will create mot_est_mb.i).

Comment 2 Charles R. Anderson 2001-11-29 16:21:29 UTC
Where do I get gcc-2.96-100 from?  The latest gcc in rawhide alpha or SRPMS is -99.



Comment 3 Charles R. Anderson 2002-03-28 01:00:24 UTC
Tried gcc-2.96-109 (gcc version 2.96 20000731 (Red Hat Linux 7.2 2.96-109) from
rawhide.  Got same error:

MPlayer-0.50/encore>gcc -save-temps -c -O4 -mcpu=ev56 -pipe -ffast-math
-fomit-frame-pointer -I. -I/usr/local/include -o mot_est_mb.o mot_est_mb.c
gcc: Warning: -pipe ignored since -save-temps specified
mot_est_mb.c: In function `MBMotionEstimation':
mot_est_mb.c:619: Internal compiler error in copy_to_mode_reg, at explow.c:789
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.

I will attach mot_est_mb.i.

Comment 4 Charles R. Anderson 2002-03-28 01:03:25 UTC
Created attachment 51004 [details]
Processed source from MPlayer-0.50/encore/mot_est_mb.c

Comment 5 Alan Cox 2002-12-15 18:11:58 UTC
Ok in gcc 3.2



Note You need to log in before you can comment on or make changes to this bug.