Bug 56365 - xawtv does not find the /dev/video0 device
xawtv does not find the /dev/video0 device
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: xawtv (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-16 01:12 EST by Joe Acosta
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-19 00:27:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Acosta 2001-11-16 01:12:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install RH 7.2
2.install xawtv from RH 7.2
3. run xawtv with appropriate device attached 
4. doe snot run 
	

Actual Results:  xawtv
This is xawtv-3.64, running on Linux/i686 (2.4.14)
can't open /dev/video0: No such device
v4l-conf had some trouble, trying to continue anyway
v4l2: open /dev/video0: No such device
v4l: open /dev/video0: No such device
no video grabber device available


Expected Results:  a video window

Additional info:

it worked in 7.1 and previous version of RH, but in 7.2 it does not. The
CPIA driver is loaded for my webcam II.

/proc/devices shows 81 video_capture

cat /proc/video/dev/video0 
name            : CPiA Camera
type            : VID_TYPE_CAPTURE
hardware        : 0x18

cat /proc/modules
parport_pc             15456   1 (autoclean)
cpia_pp                 3440   0 (autoclean) (unused)
parport                22400   1 (autoclean) [parport_pc cpia_pp]
cpia                   23376   0 [cpia_pp]
videodev                4704   3 [cpia]
Comment 1 Joe Acosta 2001-11-18 12:17:02 EST
I found this works with the default 2.4.7 kernel from teh install, but after
recompiling my kernel it does not work, even though I have the correct drivers.
 I also  had problems with 2.4.14 kernel as well.  Is there a config option that
I am missing?  

CONFIG_PARPORT=m
CONFIG_PARPORT_PC=m
CONFIG_PARPORT_PC_CML1=m
# CONFIG_PARPORT_SERIAL is not set
CONFIG_PARPORT_PC_FIFO=y
CONFIG_PARPORT_PC_SUPERIO=y
# CONFIG_PARPORT_AMIGA is not set
# CONFIG_PARPORT_MFC3 is not set
# CONFIG_PARPORT_ATARI is not set
# CONFIG_PARPORT_GSC is not set
# CONFIG_PARPORT_SUNBPP is not set
CONFIG_PARPORT_OTHER=y
CONFIG_PARPORT_1284=y

CONFIG_VIDEO_PROC_FS=y
CONFIG_I2C_PARPORT=m
# CONFIG_VIDEO_PMS is not set
# CONFIG_VIDEO_BWQCAM is not set
# CONFIG_VIDEO_CQCAM is not set
# CONFIG_VIDEO_W9966 is not set
CONFIG_VIDEO_CPIA=m
CONFIG_VIDEO_CPIA_PP=m
Comment 2 Joe Acosta 2001-11-19 00:27:10 EST
Okay after more research it turns out that it is not a redhat issue. it is an
issue that arrose in 2.4.14 kernel as the driver works in both 2.4.7 RH default,
my custom build 2.4.7 RH source and also 2.4.13 tree.

Note You need to log in before you can comment on or make changes to this bug.